1 (edited by heikkike 2011-02-22 21:36:50)

Topic: SMTP does not work in different subnet. [SOLVED]

This is solved!!!

I had a firewall in 194.xxx.xxx.55 and there was port 25 blocked.
So if you have similar issue then check your firewall in different additional subnet!

Thank you, and iRedMail rocks!!!

Debian 6
iRedMail 0.7.0-beta2 (MYSQL with no firewall rules)
Fresh install

1. I can send and receive mails via roundcube ok
2. I can receive mail from different subnet via Outlook. POP3
3. I cannot send mails out via outlook SMTP port 25 in different subnet.

iRedMail Server IP: 194.xxx.xxx.51 (no firewall etc. all connections and ports accepted for testing purpose)
Different subnet connections comes via 194.xxx.xxx.55

I have modified main.cf mynetworks: mynetworks =, 194.xxx.xxx.55
Outlook says error when testing mailaccount - "sent test e-mail message": The specified server was found but there was no response from the server. Please verify that the port and SSL information is correct.

*** Telneting from localhost, iRedMail ssh: (both IP and name ok)
  root@mail:~# telnet 194.xxx.xxx.51 25
  Connected to 194.xxx.xxx.51
  Escape character is '^]'.
  220 mail.domain.com ESMTP Postfix (Debian/GNU)

*** Telneting from 194.xxx.xxx.55 to iRedMail server via IP and Name both fails.
telnet 194.xxx.xxx.51 25
Connecting To 194.xxx.xxx.51...Could not open connection to the host, on port
25: Connect failed

Log files in iRadMail server shows nothing about failed connection attampt (mail and dovecot log)

Please help, I have digging 3 days around this problem.