Topic: Gentoo: iredapd failed to start

I decided to load up a test box with a fresh install of Gentoo yesterday and the latest iRedMail version.

Install went fairly smooth. There was a minor issue when it went to edit the php.ini file due to a version mismatch. I was able to correct that.

When I rebooted I received a message saying "iredapd failed to start". When I tried to start it manually I got the following:

* Starting iredapd ...
  File "/opt/iredapd/src/iredapd.py", line 77
    except Exception, e:
SyntaxError: invalid syntax
* start-stop-daemon: failed to start `python'                            [ !! ]
* ERROR: iredapd failed to start

I'm guessing this is a problem with python? It installed python-3.2.3.

I've tried re-emerging python, running python-updater and revdep-rebuild. Am I missing something?


Re: Gentoo: iredapd failed to start

iRedAPD doesn't work with Python-3, so please install Python-2 (python-2.7.x is recommended) and modify /etc/init.d/iredapd to use python2.7 instead:

start() {
    ebegin "Starting ${SVCNAME}"
    # Use start stop daemon to apply system limits #347301
    start-stop-daemon --start \
        --exec python2.7 ${prog} ${CONFIG}                                                                                       

    eend $?


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Gentoo: iredapd failed to start

excellent works great now!

i guess python2.7 was already on my system. just had to eselect it, run the python-updater and revdep-rebuild in order to get iredadmin working as well.