1 (edited by TraXter 2013-03-03 11:29:28)

Topic: [Solved] Upgraded to 0.8.3 - GlobalAdmin gone

==== Required information ====
- iRedMail version: 0.8.3 (Just updated)
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Linux/BSD distribution name and version:  Debian 6
- Related log if you're reporting an issue:

Hi there,

I just upgraded from 0.7.4 all through the single updates to 0.8.3 and iredamin 0.1.9 and I am facing the problem that all my domains in iredadmin are gone - it seems like I'm not globaladmin although still listed in the "admin" table.

However, after rechecking the changes I forgot to set myself as "isadmin" and "isglobaladmin" to 1 in the freshly created mailbox columns. But even after setting them I'm still not global admin or admin of a single domain. Any ideas where to start?



Re: [Solved] Upgraded to 0.8.3 - GlobalAdmin gone


as usual you search for a problem hours until you post something and just after you post it in a forum, you find out your self ...

I managed to get through the python scripts and found it is setting the global admin session when there is 'ALL' in domain_admins table. This was somehow missing for me. After adding it back I can see all domains and see myself as Global Admin in the profile. 

Thanks anyway if you read that far smile