1 (edited by sulliwane 2014-08-13 08:56:54)

Topic: Amavis won't start after an upgrade Ubuntu 12.04 -> 14.04 [SOLVED]

==== Required information ====
- iRedMail version: iRedMail-0.8.6
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Ubuntu 14.04
- Related log if you're reporting an issue:
====
Hello,

after upgrading Ubuntu server on my VPS from 12.04 to 14.04, restarting, I can't send/receive mail anymore.

I can login to my IMAP server using Roundcube or K9-mail, and send an email. But it's stuck in the SMTP server queue :

 (connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)

So looks Amavis is not running. I tried:

 /etc/init.d/amavis restart
Stopping amavisd: start-stop-daemon: warning: failed to kill 9134: No such process
(not running).
Starting amavisd: amavisd-new.

With no luck, #netstat -tap | grep amavisd gives me no process running for Amavis. I tried to restart ClamAV daemon and clamav-freshclam, as well as postfix and pastfix cluebringer. Same.

My VPS has 2Go RAM.

Thank you for your help...!

2

Re: Amavis won't start after an upgrade Ubuntu 12.04 -> 14.04 [SOLVED]

What's the output of command "/etc/init.d/amavis debug"? Any related log in /var/log/mail.log?

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

3

Re: Amavis won't start after an upgrade Ubuntu 12.04 -> 14.04 [SOLVED]

Hi,

I ran "/etc/init.d/amavis debug" and the output was very helpful:

/usr/sbin/amavisd-new[29699]: (!!)TROUBLE in pre_loop_hook: QUARANTINEDIR directory /var/lib/amavis/virusmails not writable at /usr/sbin/amavisd-new line 10926.

I messed up with some rights in the /var folder months ago, it must be related.

I "chown -R amavis: /var/lib/amavis/virusmails" restarted the server and everything went smoothly again, I can send and receive mails.

谢谢! without your great work, I would not be running my own mail server as the whole stack is too much of a trouble for me.