1 (edited by kmihalj 2015-02-09 20:24:42)

Topic: This should be in iredmail by default (/etc/postfix/main.cf)

==== Required information ====
- iRedMail version: 0.9.0
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: CentOS 7
- Related log if you're reporting an issue:
====

I been fighting with users using Outlook for sending mail's, and theirs claims that mails are not received by thoose to whom are sent...

In log's I have bunch of entires like this....
postfix/smtpd[32424]: warning: Illegal address syntax from xxxxx in RCPT command: <'some.mail@mailserver'>

Well, for some reason Outlook add apostrophes...  All other mail clients are OK and they don't do that.

FIX:
In main.cf (/etc/postfix/main.cf) add at bottom line

smtpd_command_filter = pcre:/usr/local/etc/postfix/command_filter

and create file /usr/local/etc/postfix/command_filter with this contect

/^RCPT\s+TO:\s*<'([^[:space:]]+)'>(.*)/     RCPT TO:<$1>$2

Source of fix is http://yvanrodrigues.com/content/server … ess-syntax

Afther that fix in log I have now:

Feb  9 09:08:50 iredmail postfix/smtpd[32424]: warning: Illegal address syntax from xxxxx[xxxxxx] in RCPT command: <'some.mail@mailserver'>
Feb  9 09:09:52 iredmail postfix/smtpd[780]: xxxx[xxxxxx]: replacing command "RCPT TO: <'some.mail@mailserver'>" with "RCPT TO:<some.mail@mailserver>"
Feb  9 09:10:00 iredmail amavis[944]: (00944-01) Passed CLEAN {RelayedInternal}, MYNETS/MYUSERS LOCAL [xxxxxxx]:52167 <xxxxxx@xxxxx.hr> -> <some.mail@mailserver>, Queue-ID: 5294D201031F4F, Message-ID: <009401d0443f$c9500f40$5bf02dc0$@xxxx.hr>, mail_id: sMgZzKezQ5hF, Hits: -, size: 8708, queued_as: F258C201031F66, dkim_new=dkim:xxx.hr, 250 ms

Me happy, users happy smile

2

Re: This should be in iredmail by default (/etc/postfix/main.cf)

May i know which Outlook version your client is running?

== UPDATE ==

I did a quick search with Google, looks like Outlook 2003/2007 has this issue.

It's a mail client program issue, not a server-side issue. Personally, I suggest you ask your user to contact these senders, tell them they need to update their Outlook. Because you solved this issue on your server, it will occur on other mail servers too. Let's fix the root cause - Outlook 2003/2007.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

3 (edited by kmihalj 2015-02-10 21:55:57)

Re: This should be in iredmail by default (/etc/postfix/main.cf)

I personally updated few Outlooks 2003/2007 to 2010 and 2013 .... but existing addressbooks are untouched and mail addresses are still with apostrophes.... I know that Outlook is root of problem, but it's easier for me to solve problem on server side... and somebody may also need this fix, so I post it to be avaliable for thoose in need.

4

Re: This should be in iredmail by default (/etc/postfix/main.cf)

Thanks for sharing.

I prefer to leave it to iRedMail server admins who have this issue, because it's a MUA issue, not server issue. That means i won't integrate this solution in iRedMail.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

5

Re: This should be in iredmail by default (/etc/postfix/main.cf)

This issue affects all iredmail servers , and causes email undeliverability.

Please reconsider adding this simple fix.

6

Re: This should be in iredmail by default (/etc/postfix/main.cf)

It's now enabled by default (for Postfix 2.7+):
https://bitbucket.org/zhb/iredmail/comm … 225fb2cc22

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee