Topic: Postfix doesn't connect to amavisd


I have FreeBSD 9.0 fresh installation with iRedMail-0.7.4 . I know that it is officially unsupported but I tried. It installed almost fine, I mean that it needed some googling and a little bit help, you know postfix and cyrusSALS2.

But now I cannot find anything related to this on Google.

I have FreeBSD 9.0, backend is LDAP. Postfix cannot connect to the amavis but it accepts mail in the queue but thats all. Everything else I think works normally. I didn't change any settings related to amavisd or postfix.

postfix/qmgr[1219]: 3C877BACD: from=<root@bsd.domain.cz>, size=2111, nrcpt=1 (queue active)
postfix/qmgr[1219]: warning: connect to transport private/smtp-amavis: No such file or directory
postfix/error[1236]: 3C877BACD: to=<root@bsd.domain.cz>, relay=none, delay=77704, delays=77703/1.4/0/0.17, dsn=4.3.0, status=deferred (mail transport unavailable)
postfix/postfix-script[1208]: warning: /var/spool/postfix/etc/resolv.conf and /etc/resolv.conf differ

here is: postconf -n

alias_database = hash:/usr/local/etc/postfix/aliases
alias_maps = hash:/usr/local/etc/postfix/aliases
allow_min_user = no
biff = no
bounce_queue_lifetime = 1d
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
content_filter = smtp-amavis:[]:10024
daemon_directory = /usr/libexec/postfix
data_directory = /var/db/postfix
debug_peer_level = 2
delay_warning_time = 0h
disable_vrfy_command = yes
enable_original_recipient = no
home_mailbox = Maildir/
html_directory = /usr/share/doc/postfix
inet_interfaces = all
inet_protocols = ipv4
mail_owner = postfix
mailbox_command = /usr/local/libexec/dovecot/deliver
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
maximal_backoff_time = 4000s
maximal_queue_lifetime = 1d
message_size_limit = 15728640
minimal_backoff_time = 300s
mydestination = $myhostname, localhost, localhost.localdomain, localhost.$myhostname
mydomain = domain.cz
myhostname = bsd.domain.cz
mynetworks =
mynetworks_style = subnet
myorigin = bsd.domain.cz
newaliases_path = /usr/bin/newaliases
proxy_read_maps = $canonical_maps $lmtp_generic_maps $local_recipient_maps $mydestination $mynetworks $recipient_bcc_maps $recipient_canonical_maps $relay_domains $relay_recipient_maps $relocated_maps $sender_bcc_maps $sender_canonical_maps $smtp_generic_maps $smtpd_sender_login_maps $transport_maps $virtual_alias_domains $virtual_alias_maps $virtual_mailbox_domains $virtual_mailbox_maps $smtpd_sender_restrictions
queue_directory = /var/spool/postfix
queue_run_delay = 300s
readme_directory = /usr/share/doc/postfix
recipient_bcc_maps = proxy:ldap:/usr/local/etc/postfix/ldap/recipient_bcc_maps_domain.cf, proxy:ldap:/usr/local/etc/postfix/ldap/recipient_bcc_maps_user.cf
recipient_delimiter = +
relay_domains = $mydestination, proxy:ldap:/usr/local/etc/postfix/ldap/relay_domains.cf
sample_directory = /etc/postfix
sender_bcc_maps = proxy:ldap:/usr/local/etc/postfix/ldap/sender_bcc_maps_domain.cf, proxy:ldap:/usr/local/etc/postfix/ldap/sender_bcc_maps_user.cf
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_data_init_timeout = 240s
smtp_data_xfer_timeout = 600s
smtpd_data_restrictions = reject_unauth_pipelining
smtpd_enforce_tls = no
smtpd_helo_required = yes
smtpd_helo_restrictions = permit_mynetworks,permit_sasl_authenticated, check_helo_access pcre:/etc/postfix/helo_access.pcre
smtpd_recipient_restrictions = reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unlisted_recipient, check_policy_service inet:, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_non_fqdn_helo_hostname, reject_invalid_helo_hostname, check_policy_service inet:
smtpd_reject_unlisted_recipient = yes
smtpd_reject_unlisted_sender = yes
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = no
smtpd_sasl_local_domain = 
smtpd_sasl_path = ./dovecot-auth
smtpd_sasl_security_options = noanonymous
smtpd_sasl_type = dovecot
smtpd_sender_login_maps = proxy:ldap:/usr/local/etc/postfix/ldap/sender_login_maps.cf
smtpd_sender_restrictions = permit_mynetworks, reject_sender_login_mismatch, permit_sasl_authenticated
smtpd_tls_CAfile = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_cert_file = /etc/ssl/certs/iRedMail_CA.pem
smtpd_tls_key_file = /etc/ssl/private/iRedMail.key
smtpd_tls_loglevel = 0
smtpd_tls_security_level = may
tls_random_source = dev:/dev/urandom
transport_maps = proxy:ldap:/usr/local/etc/postfix/ldap/transport_maps_user.cf, proxy:ldap:/usr/local/etc/postfix/ldap/transport_maps_domain.cf
unknown_local_recipient_reject_code = 550
virtual_alias_domains = 
virtual_alias_maps = proxy:ldap:/usr/local/etc/postfix/ldap/virtual_alias_maps.cf, proxy:ldap:/usr/local/etc/postfix/ldap/virtual_group_maps.cf, proxy:ldap:/usr/local/etc/postfix/ldap/sender_login_maps.cf, proxy:ldap:/usr/local/etc/postfix/ldap/catchall_maps.cf
virtual_gid_maps = static:1001
virtual_mailbox_base = /usr/vmail
virtual_mailbox_domains = proxy:ldap:/usr/local/etc/postfix/ldap/virtual_mailbox_domains.cf
virtual_mailbox_maps = proxy:ldap:/usr/local/etc/postfix/ldap/virtual_mailbox_maps.cf
virtual_minimum_uid = 1001
virtual_transport = dovecot
virtual_uid_maps = static:1001

I promise if everything goes well I'll write step-by-step tutorial. Thank you.==== Provide required information to help troubleshoot and get quick answer ====
- Linux/BSD distribution name and version:
- iRedMail version and backend (LDAP/MySQL):
- Any related log? Log is helpful for troubleshooting.


Re: Postfix doesn't connect to amavisd

You have 'content_filter = smtp-amavis:[]:10024' in Postfix, but do you have transport 'smtp-amavis:[]:10024' defined in /usr/local/etc/postfix/master.cf? Please paste this file to help troubleshoot.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Postfix doesn't connect to amavisd

Here it is.

submission inet n       -       n       -       -       smtpd
  -o smtpd_enforce_tls=yes
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_client_restrictions=permit_mynetworks,permit_sasl_authenticated,reject
#  -o content_filter=smtp-amavis:[]:10026

# Use dovecot deliver program as LDA.
dovecot unix    -       n       n       -       -      pipe
    flags=DRhu user=vmail:vmail argv=/usr/local/libexec/dovecot/deliver -f ${sender} -d ${user}@${domain}
smtp-amavis unix -  -   -   -   2  smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes
    -o disable_dns_lookups=yes
    -o max_use=20 inet n  -   -   -   -  smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_delay_reject=no
    -o smtpd_client_restrictions=permit_mynetworks,reject
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks_style=host
    -o mynetworks=
    -o strict_rfc821_envelopes=yes
    -o smtpd_error_sleep_time=0
    -o smtpd_soft_error_limit=1001
    -o smtpd_hard_error_limit=1000
    -o smtpd_client_connection_count_limit=0
    -o smtpd_client_connection_rate_limit=0
    -o receive_override_options=no_header_body_checks,no_unknown_recipient_checks,no_address_mappings

4 (edited by Mums 2012-02-24 02:33:36)

Re: Postfix doesn't connect to amavisd

Edit 19:32 : Still the same error as before.

OK fixed, this was the problem. wink

#  -o content_filter=smtp-amavis:[]:10026

It should be:

  -o content_filter=smtp-amavis:[]:10024

But the mail is still not going to mailboxes. I'll look at it later, now I don't have time for it.


Re: Postfix doesn't connect to amavisd

It works finaly. smile

in amavisd.conf I needed to chande this:
$inet_socket_port = [10024, 9998];

to this:
$inet_socket_port = [10024];

So after one month e-mail is working but I started with tests of iRedMail just 5 days ago. This tool is just awesome! Thank you. smile


Re: Postfix doesn't connect to amavisd

I am also facing same issue , i did all the steps mentioned above but my issue is not resolved .Ply help me


Re: Postfix doesn't connect to amavisd

bangram wrote:

I am also facing same issue , i did all the steps mentioned above but my issue is not resolved .Ply help me

just in case anyone faces this...

Is Amavis running?? Make sure it is!