Topic: Error on install - 0.8.3 on Ubuntu 12.04

==== Required information ====
- iRedMail version: 0.8.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Linux/BSD distribution name and version: Ubuntu 12.04
- Related log if you're reporting an issue:

My install is not on a bare-metal server, but on a XenServer 6.0 VM with Ubuntu 12.04 64-bit. Hope this does not influence the installation.

I am following the install guide shown here:

Several issues:

1. I chose the LDAP backend, but the installer
       - does not ask me for LDAP suffix,
       - does not ask for password of LDAP root dn
       - does not ask for password of MySQL root user (maybe it should not, not clear from install doc)

2. After entering name of first domain, it comes to the screen "Password for the administrator of the first domain"
Instead of saying "postmaster@mydomain.com"
it says
   postmaster@libpgm: zero screen dimension, assuming 80x25.

In other words, it included the text of some cryptic error message into the user name of the admin user!

3. Right after this, it is supposed to come up with a screen to enter a password for the first user.
    It does not do that. Instead it quits the installer.
    Also the screen for optional components which is meant to show does not show.

4. When it quits the installer, it gives following error message:

cat: /root/iRedMail-0.8.3/.optional_components: No such file or directory
Configuration completed.

I choose to continue afterwards and it does downloads and installations afterwards.
A couple of error messages come up in-between.
Is there an install log somehwere? What I am posting here, is what I caught, it might not be all:

grep: /etc/ssh/sshd_config: No such file or directory
< Question > Would you like to use firewall rules provided by iRedMail now?
< Question > File: /etc/default/iptables, with SSHD port: 22. [Y|n]y
< INFO > Copy firewall sample rules: /etc/default/iptables.
< Question > Restart firewall now (with SSHD port 22)? [y|N]y
< INFO > Restarting firewall ...
* Applying iptables firewall rules       [ OK ]

/root/iRedMail-0.8.3/functions/cleanup.sh: line 227: [: too many arguments
Usage: dovecot-lda [-c <config file>] [-a <address>] [-d <username>] [-p <path>]
                   [-f <envelope sender>] [-m <mailbox>] [-e] [-k]
lda(root): Fatal: Unknown argument: zero
Usage: dovecot-lda [-c <config file>] [-a <address>] [-d <username>] [-p <path>]
                   [-f <envelope sender>] [-m <mailbox>] [-e] [-k]
lda(root): Fatal: Unknown argument: zero

< INFO > Updating ClamAV database (freshclam), please wait ...
ClamAV update process started at Mon Feb 18 19:55:08 2013

5. The file iRedMail.tips contains this weird message "libpgm: zero screen dimension, assuming 80x25." all over, so I guess I cannot login anywhere.

6. Per the instructions, I am supposed to be able to "access webmail and other web applications" by browsing to
http://your_server/mail   (or /webmail,   /roundcube).
None of them work.

What do I need to do?
I have paid $299 for iRedAdmin panel, but I don't even get to the install of that, since I am blocked with the mail server setup due to above errors.

Pleast let me know what needs to be done to resolve this.


Re: Error on install - 0.8.3 on Ubuntu 12.04

Hi pschulz,

First of all, thanks very much for purchasing iRedAdmin-Pro to support iRedMail project.

The reason why we ask to use a FRESH OS is avoiding issues like yours, too many things we cannot know on your server. But with a FRESH OS, everything is under control.

So, my suggestion is, reinstall your OS on Xen with minimal packages, then try iRedMail.

P.S. If you're using Windows workstation and connect to server with SecureCRT as ssh client, there may be issue while configuring iRedMail. Please try other SSH client instead. e.g. Putty.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Error on install - 0.8.3 on Ubuntu 12.04

Thanks for the message.
I re-installed a fresh server another 2 times, with exactly the same messages.
It is a 64-bit Ubuntu 12.04 server. When the Ubuntu server install comes to the point of asking to select additional packages, I select none at all. I also tried to select BASIC SERVER but this gives me the same result.

The Ubuntu install on Xen is a network install from the URL http://archive.ubuntu.com/ubuntu/.
I have done many installs from there for other servers, with no problems.
Have done literally nothing between server install and attempting to start the iRedMail installer.

i  noticed at the beginning of the install following lines, where it tries to get some packages from iRedmail.org - it is downloading from a folder called /yum/ - but I am on Ubuntu? There is no yum.
It might just be  that you named the folder yum for all distributions, or is it?

INFO > + 4 of 6: http://iredmail.org/yum/misc/phpMyAdmin … es.tar.bz2
< INFO > + 5 of 6: http://iredmail.org/yum/misc/iRedAPD-1.3.8.tar.bz2
< INFO > + 6 of 6: http://iredmail.org/yum/misc/phpPgAdmin-5.0.4.tar.bz2
< INFO > Validate packages ...md5sum: WARNING: 1 line is improperly formatted
[ OK ]
< INFO > Install package: dialog
< INFO > Installing package(s): dialog
Reading package lists... Done
Building dependency tree       
Reading state information... Done

Does this just not work on Ubuntu? I can try CentOS if it works better, I am just more familiar with Ubuntu server.


Re: Error on install - 0.8.3 on Ubuntu 12.04

I must conclude that the Ubuntu installer is actually broken - it is bugged, does not work.

For comparison, I now tried an install on CentOS. Interestingly, here the "install wizard" actually looks like the install document says it should look like, and it does complete, including the optional components.

So once again, the iRedMail Ubuntu installer is obviously bug-ridden.
If you look at what I posted above, the install wizard thinks that it needs to find a folder .optional_components - and in fact, it is not there on my server:

cat: /root/iRedMail-0.8.3/.optional_components: No such file or directory

Also a locate does not find any such folder.

Do I have a chance to get it installed on Ubuntu, or do I have to stick with CentOS then?


Re: Error on install - 0.8.3 on Ubuntu 12.04

Is it possible for you to install Ubuntu on a physical server, or VMware, instead of Xen? as a test.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Error on install - 0.8.3 on Ubuntu 12.04

Have not been able yet to make a test-install on physical server for Ubuntu.

But did an install on CentOS which did behave normally, the first 2 times at least. Again as a XenServer VM.

I did this install 3 times, and I noticed that the install wizard error seems to come from the screen where I am meant to select the backend (LDAP, MySQL etc).
This screen behaves very awkwardly under CentOS and also under Ubuntu. One cannot move the cursor.
I find no way to select the NEXT button.
The only way I found was pressing Alt+N, then it goes further, but in that case it seems to go two screens further (skipping the LDAP domain and MySQL password entry), seemingly this indicates LDAP is NOT selected.
Also when this happens, then every time I do NOT get the optional components screen.

In CentOS, I cannot change the backend options. If I press the space bar, it sometimes manages to jump to PostgreSQL. Next few presses does not change anything. I cannot select the NEXT. I then use Alt-N again as above, but then I get the SAME ERROR as I had in Ubuntu - does not ask for LDAP domain or MySQL password and the optional-components screen is missing, and it gives this error message upon completion as noted above (cannot find optional_components).

The only way I found was to just don't even try to select anything but press ENTER. Then it works and then it also does show the optional_components screen and completes correctly.

Looks like my above-mentioned bug is related to this screen of the installer.


Re: Error on install - 0.8.3 on Ubuntu 12.04

Update - did another install on Ubuntu 12.04, still on XenServer VM - and it did work, as long as I refrained from selecting anything in that ominous backend screen of the installer.
I just pressed ENTER, since my desired version was LDAP, and that's the default. Then it worked.

But this is of course a problem for anyone not desiring the LDAP backend.
Will try a physical Ubuntu install next, to see if the installer behaves properly then


Re: Error on install - 0.8.3 on Ubuntu 12.04

According to your last post, looks like there's something unexpected with your terminal. May i know which terminal program/application you used to install iRedMail? Putty? or connect from another Linux/BSD server/workstation?

iRedMail uses "dialog" program for installation wizard (the dialog prompts you to choose backends, optional components, etc), it doesn't work well with SecureCRT (a Windows ssh client), but it should work well on most SSH clients since we didn't get complains about it.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Error on install - 0.8.3 on Ubuntu 12.04

i am using XenCenter, that's the application which is the standard management program for XenServer (runs on Windows only) - it includes a console which acts like an SSH session, at least it does look like it.

Makes sense that this is related to the problem, as the error which puts itself into the mail box name is about screen resolution problems.
On CentOS, the installer looks different on that console (no colors), even though it also misbehaves.
As mentioned, I did manage to install iRedMail on Ubuntu anyway in the end - just clicking Enter on that screen.

I'll try it on a physical server still if I get around to it, but otherwise thanks for the assistance.


Re: Error on install - 0.8.3 on Ubuntu 12.04

Could you please try to use a standalone SSH client (e.g. Putty) instead of the Xen console? I think it should solve this issue.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee