Topic: No search results

==== Required information ====
- iRedMail version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Linux/BSD distribution name and version:
- Related log if you're reporting an issue:
==== ==== Required information ====
- iRedAdmin-Pro-MySQL-1.6.0
- Ubuntu 12.04.2 LTS

I've just upgraded to the Pro version today.  Love this Admin Panel.  Strange though, when I try and locate an email address via the search box, I get no results.  Searching on just the username and/or the username@domain.  Any idea why?

Thank you,



Re: No search results

It might be a bug of iRedAdmin-Pro-MySQL-1.6.0, i will try to reproduce this issue. Will get back to you later.
Thanks for your feedback. smile


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: No search results

ZhangHuangbin, thanks for the prompt response!!  Depending on your debug time/resource, is it possible to install the previous version?  I'm migrating 5000k+ email accounts this weekend from three different mail servers/companies (sendmail/qmail/Ability Mail).  The search feature was a key tool I was going to need.

Thank you very much smile


Re: No search results

it's confirmed that this is a bug in iRedAdmin-Pro-MySQL-1.6.0 (and iRedAdmin-Pro-PGSQL-1.2.0). I fixed it moment ago, attachment is the patch for iRedAdmin-Pro-MySQL-1.6.0. You can apply it with below steps:

1) Download attached patch, upload it to your server which has iRedAdmin-Pro-MySQL-1.6.0 running. Assume uploaded file is

2) Change working directory to the root directory of iRedAdmin-Pro-MySQL-1.6.0. For example:

# cd /var/www/iRedAdmin-Pro-MySQL-1.6.0/

3) Verify the patch with command 'patch --dry-run -p1':

# patch --dry-run -p1 < /root/mysql_search.patch
patching file libs/mysql/connUtils.py

4) If you got the SAME output message, it's safe to apply it without '--dry-run' immediately:

# patch -p1 < /root/mysql_search.patch

5) Restart Apache web server to reload patched file.

That's all. Let me know whether it works for you or not.

P.S. If you're not familiar with patching source file, please mail me to get a patched version.

Post's attachments

mysql_search.patch 620 b, 2 downloads since 2013-04-28 

You don't have the permssions to download the attachments of this post.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: No search results

Zhang... Problem solved!  Thank you very very much!