Topic: Official Ubuntu 10.04 Support

Hey there!

You wrote some time ago, that you'll test iRedmail on Ubuntu 10.04 after it has been released. Have you tested it? Can I run iRedMail on 10.04 without complications. Is there any timeframe, when 10.04 is officially supported?

Thanks in advance!



Re: Official Ubuntu 10.04 Support

I'm wondering the same thing. I would really love to use iRedMail on top of Ubuntu 10.04. Any news or plans on this would be really appreciated.



Re: Official Ubuntu 10.04 Support

Sorry, so busy these days (my full-time job).

You can help test it and report any issues here.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Official Ubuntu 10.04 Support

I've tried it, but it trips up on installing postfix-policyd. It looks like a ubuntu issue rather than iRed issue. Launchpad has a few things logged against it but no definite fix.


Re: Official Ubuntu 10.04 Support

Yes, you can try to install postfix-policyd manually first, and then install iRedMail.


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Official Ubuntu 10.04 Support

I can verify that the installation complains at postfix-policyd.

I am not a debconf guru by any means, but did some digging. What appears to be happening is that the mysql database selection is not being picked up in the pre-inst phase. This seems to have the effect of defaulting to a postgres database and setting a config variable that does not exist. I tried hacking the debconf scripts but got stuck further along, and have been too busy to get back to it.


Re: Official Ubuntu 10.04 Support

I have report the bug to ubuntu, but have not fix until now.

https://bugs.launchpad.net/ubuntu/+sour … bug/560144

anyone can help to fix it.


Re: Official Ubuntu 10.04 Support

I've found if I install 10.04 (lucid), updates, and then apt-get install dbconfig-common, then postfix-policyd, it does not complain.

Running iRedMail.sh after that does not try to install the older version of postfix-policyd (which appears to depend on the broken dbconfig-common).

If you run the cleanup scripts, and try to rerun iRedMail.sh, it will complain again. You have to apt-get purge both postfix-policyd and dbconfig-common. This is not surprising since the cleanup script will remove the current versions and then the iRedMail.sh script will pick up the wrong versions again.

9 (edited by rhollan 2010-07-05 16:04:50)

Re: Official Ubuntu 10.04 Support

More progress. Actually, I am not installing on ubuntu 10.04 (lucid), but rather mythbuntu 10.04, which is a 10.04 derivative that removes all the stuff not necessary for mythtv. Therefore, extra packages need to be added. I started with the debian specific list in MD5.debian.

So far, this is what I did:

1. Install mythbuntu 10.04 from CD. http://www.mythbuntu.org/10.04/release

2. Enable mythbuntu updates, and install them (directions at http://www.mythbuntu.org/auto-builds).

3. Install dbconfig-common and postfix-policyd (sudo apt-get install dbconfig-common postfix-policyd). Create the database for postfix-policyd when asked.

4. Install postix and dovecot. (sudo apt-get install dovecot postfix)

5. Download and untar iRedMail 0.6.0. (wget http://iredmail.googlecode.com/files/iR … 0.tar.bz2; tar -jxvf iRedMail-0.6.0.tar.bz2).

6. Install iRedMail dependencies. install all packages in pkgs/MD5.debian (EXCEPT postfix-policyd) using apt-get, and pkgs/MD5.misc. I copied the latter into pkgs/MD5.ubuntu.lucid, and ran the get_all.sh script to take advantage of it detecting Ubuntu lucid. There is a fix for jaunty to create a missing postfix-policyd table in mysql (blacklist_dnsname), that isn't picked up tor lucid, but the updated postfix-policyd installed in step 3 has fixed that bug).

7. Ran iRedMail.sh but JUST create the config file.

8. Because Mythbuntu installs a LAMP stack, I edited conf/global to set USE_EXIST_AMP to 'YES' instead of 'NO' and conf/mysql to set MYSQL_FRESH_INSTALLATION to 'NO' instead of YES.

9. Then I reran iRedMail.sh and accepted the already-created config file.

Well, after all that restarting things and connecting to the server /mail, /ldap , and mysql gave me what was expected, but I could not log in as the first mail user (www@<domain>). Further, neither dovecot nor postfix were recognizing the first www user. Not sure how to debug their interaction with slapd.

At this point, I am open to suggestions. I suspect that much of what I did would work for stock Ubuntu 10.04 (lucid), perhaps with less of a need to install all the packages that already ship with it. The biggie was getting postfix-policyd to install.

On edit: I also had to install php5-ldap: sudo apt-get install php5-ldap.


Re: Official Ubuntu 10.04 Support

O.K. I redid the above steps, remembering to install postfix BEFORE postfix-policyd this time.

Both postfix and dovecot now recognize the www@<domain> user!

But, still no go with the roundcubemail web interface.

I'd really like some assistance with getting roundcube working.


Re: Official Ubuntu 10.04 Support

Got roundcube working!

In /usr/share/apache2/roundcubemail/config/db.inc.php, I had to make the following change:

$rcmail_config['db_dsnw'] = "mysql://roundcube:<password here>@localhost/roundcubemail";

mysql was originally mysqli.

Not sure why that was the case.

But, have now verified that mail is accepted by postfix for the initial user (www@<domain>, available via pop3 (and, presumably imap), and no via the roundcubemail web interface.

I have not yet tried adding other users.

sieve filtering is not yet working, but that's not as much of a priority right now as pop, imap, and web-access.


Re: Official Ubuntu 10.04 Support

hi rhollan

Thank you for your test.

Now the policyd problem have been fixed. you can check out the newest version iRedMail test it. Now the RoundCube problem have not fix, but later would deal with it.


Re: Official Ubuntu 10.04 Support

Thanks, shake. It was a long slog to get it working. First, the postfix-policyd issue, then missing packages.

It would have been a bit easier if the dependencies were clear. It took me a while to realize that get_all.sh would only retrieve what it thought it needed for the distro on which it was installing and not just what was actually MISSING. Also, figuring how to install on an EXISTING LAMP stack took some googling.

In my case, I installed on Mythbuntu 10.04: a Ubuntu 10.04 derivative optimized for TV recording and playback -- for now, I am running all my remotely accessible servers on a single box, even if some services require authentication (like controlling my recording schedule) and would not normally be exposed (hey, I like to control what I record remotely).

It seemed easier to start with a distro optimized to the applications having the most package interdependencies, and add other services on top of that. At first, I figured I'd just do postfix and dovecot with LDAP-bassed authentication of virtual domains from scratch, and then came across iRedMail in my searches, and figured if someone else has done the integration, I may as well leverage their work. The problem, of course, is that I didn't find the integration effort done well documented, and putting together the missing pieces in my environment proved a bit of an effort.

I ALMOST gave up, installed full Ubuntu 10.04, then iRedMail, and mythtv on top of that, struggling with ITS interdependencies, but gave iRedMail one more chance, and started making progress.

Still don't have sieve running, apparently, but postfix, dovecot, and web-based mail work, and those are the biggies. Whee! No more unix user accounts for mail for my family members. Tonight, I plan to install real certificates. Does anyone know if roundcubemail talks imap or imaps locally to dovecot? If imap, then no worries, but if imaps, then I will have to figure out how to adjust the root certs it trusts. (My guess would be imap if dovecot was presumed local (on the same box), but if remote mail servers were supported, then imaps might have been an option.)