26

Re: iRedMail-0.9.8 has been released

darth_wells wrote:

Apr 11 10:00:20 dict(16164): Error: Couldn't load plugin /usr/lib/dovecot/modules/dict/libdriver _pgsql.so: Module is for different ABI version 2.0.18 (we have 2.2.ABIv35(2.2.35))

Do you have package "dovecot-pgsql" installed? And maybe you forgot to update it?

Which yum/apt repo do you use for Dovecot-2.2.35?

27

Re: iRedMail-0.9.8 has been released

ZhangHuangbin wrote:
darth_wells wrote:

My SQL login failed after changes
dovecot-mysql.conf

Why did you comment out other parameters in dovecot-mysql.conf? Just replace the 'password_query =' line.

I tried just replacing the 'password_query =' line.

Apr 13 08:17:10 auth-worker(3021): Error: sql(wells@thedarktimes.us,127.0.0.1,<+0oZsLpp4JF/AAAB>): Password query failed: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '= SELECT CONCAT(mailbox.storagebasedirectory, '/', mailbox.storagenode, '/', mai' at line 1

28

Re: iRedMail-0.9.8 has been released

darth_wells wrote:

Password query failed: You have an error in your SQL syntax

Did you copy the full line?

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

29

Re: iRedMail-0.9.8 has been released

ZhangHuangbin wrote:
darth_wells wrote:

Password query failed: You have an error in your SQL syntax

Did you copy the full line?

I tried this

password_query = SELECT mailbox.password, mailbox.allow_nets \
user_query = SELECT \
    CONCAT(mailbox.storagebasedirectory, '/', mailbox.storagenode, '/', mailbox.maildir) AS home$
    CONCAT('*:bytes=', mailbox.quota*1048576) AS quota_rule \
FROM mailbox,domain \
WHERE mailbox.username='%u' \
    AND mailbox.domain='%d' \
    AND mailbox.`enable%Ls%Lc`=1 \
    AND mailbox.domain=domain.domain \
    AND domain.backupmx=0 \
    AND domain.active=1 \
    AND mailbox.active=1

30

Re: iRedMail-0.9.8 has been released

darth_wells wrote:

password_query = SELECT mailbox.password, mailbox.allow_nets \
user_query = SELECT ...

You see the error in red color?

"user_query =" is a parameter, "password_query =" is another parameter.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

31

Re: iRedMail-0.9.8 has been released

Not installing on Ubuntu 18.04 LTS

Package zoo is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

This was obsoleted, checked dependencies and 'amavisd-new-postfix' uses it.

Package php-mcrypt is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Apparently this was fixed but it seems roundcube still asks for it.
Debian bug: https://bugs.launchpad.net/ubuntu/+sour … ug/1749745

32

Re: iRedMail-0.9.8 has been released

Faw wrote:

Not installing on Ubuntu 18.04 LTS

We didn't test iRedMail-0.9.8 on Ubuntu 18.04 BETA yet. Will try soon.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

33

Re: iRedMail-0.9.8 has been released

Hi, ZhangHuangbin

I need alternative site to download iRedMail-0.9.8 and the others files packs, because i don't have access to https://bitbucket.org/

Thank you