1

Topic: Illegal address syntax

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 0.9.8
- Linux/BSD distribution name and version: CentOS 7
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? Yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Some users report that they cannot send emails via outlook. We checked the maillog and found that the reason is a single quotes inside the mail address as below:

Nov 20 23:12:02 mx postfix/submission/smtpd[31661]: warning: Illegal address syntax from aaa.aaa.com[1.1.1.1] in RCPT command: <'bbb@gmail.com'>

We checked the end user's outlook, they add the mail address normally and nothing special. But don't know why some of the email address they added have a single quotes inside when sending out. It's also happened on other user who using outlook 2010 and 2016.

Is it possible auto filter the single quotes out if any when sending out email?

Thanks a lot.

Regards,
Matt

2

Re: Illegal address syntax

Check file /etc/postfix/main.cf, find line below, enable it by removing the leading '#', then restart postfix service.

smtpd_command_filter = pcre:/etc/postfix/command_filter.pcre

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee