1 (edited by fr 2019-03-13 17:55:00)

Topic: some email does not arrive

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 0.9.9
- Deployed with iRedMail Easy or the downloadable installer? download
- Linux/BSD distribution name and version: OpenBSD
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MariaDB
- Web server (Apache or Nginx):Nginx
- Manage mail accounts with iRedAdmin-Pro? No
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====



Good morning. Some colleagues, since I installed iredmail, complain that some emails do not arrive. I completely disabled clamav, amavisd and spamassassin and now iredapd but still no improvement.
Some idea? Thank you

2

Re: some email does not arrive

In the /var/log/maillog i have this report

Mar 13 16:16:45 mail postfix/smtpd[94750]: NOQUEUE: reject: RCPT from mx.outsender.com[xx.xx.xx]: 450 4.7.1 <post.out.com>: Helo command rejected: Host not found; from=<name@domain.com> to=<dest@otherdomain.com> proto=ESMTP helo=<post.out.com>

I therefore think that the problem is smtp helo command reject.
In the postfix/main.cf i have:

# HELO restriction - edita qua no<->yes
smtpd_helo_required = no
smtpd_helo_restrictions =
    permit_mynetworks
    permit_sasl_authenticated
    check_helo_access pcre:/etc/postfix/helo_access.pcre
    reject_non_fqdn_helo_hostname
    reject_unknown_helo_hostname


how i disable this?????

3

Re: some email does not arrive

Instead of disable HELO checks, you'd better whitelist it like this:

- Prepend below in to head of file /etc/postfix/helo_access.pcre:

/^post\.out\.com$/ OK

- Reload postfix service.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

4 (edited by fr 2019-03-19 18:15:56)

Re: some email does not arrive

I'm sorry, but even so I still have problems.
the only way to make it work is this:

# HELO restriction
smtpd_helo_required = no
smtpd_helo_restrictions =
     permit_mynetworks
     permit_sasl_authenticated
     check_helo_access pcre: /etc/postfix/helo_access.pcre
# reject_non_fqdn_helo_hostname
# reject_unknown_helo_hostname





ZhangHuangbin wrote:

Instead of disable HELO checks, you'd better whitelist it like this:

- Prepend below in to head of file /etc/postfix/helo_access.pcre:

/^post\.out\.com$/ OK

- Reload postfix service.