1

Topic: Error nginx (emerg) php_workers

Mysql  5.7.25-0ubuntu0.18.04.2
Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-47-generic x86_64)
iRedMail version 0.9.9


Logs


root@mail:~# systemctl status nginx.service
● nginx.service - A high performance web server and a reverse proxy server
   Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2019-04-08 14:28:31 WEST; 1min 4s ago
     Docs: man:nginx(8)
  Process: 3022 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)

abr 08 14:28:30 mail systemd[1]: Starting A high performance web server and a reverse proxy server...
abr 08 14:28:30 mail nginx[3022]: nginx: [emerg] no port in upstream "php_workers" in /etc/nginx/templates/fastcgi_php.tmpl:14
abr 08 14:28:31 mail nginx[3022]: nginx: configuration file /etc/nginx/nginx.conf test failed
abr 08 14:28:31 mail systemd[1]: nginx.service: Control process exited, code=exited status=1
abr 08 14:28:31 mail systemd[1]: nginx.service: Failed with result 'exit-code'.
abr 08 14:28:31 mail systemd[1]: Failed to start A high performance web server and a reverse proxy server.



who can help or help with solving this problem?

2

Re: Error nginx (emerg) php_workers

Do you have file /etc/nginx/conf-enabled/php-fpm.conf? it's a symbol link to /etc/nginx/conf-available/php-fpm.conf. its content looks like this:

upstream php_workers {
    server 127.0.0.1:9999;
}

Also, make sure your php-fpm service is running and listening on port 9999.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee