1

Topic: uninstall iRedMail

==== Required information ====
- iRedMail version (check /etc/iredmail-release):
- Linux/BSD distribution name and version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Web server (Apache or Nginx):
- Manage mail accounts with iRedAdmin-Pro?
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
======== Required information ====
- iRedMail version (check /etc/iredmail-release):
- Linux/BSD distribution name and version: ubuntu 16.04 LTS
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Web server (Apache or Nginx): apache
- Manage mail accounts with iRedAdmin-Pro?
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Hi,

I'd like to uninstall iRedMail completely, and reinstall it later on.
The problem when i try to download the script mentioned in this post
How to uninstall iRedMail it gives me "ERROR 404: Not Found."

what should i do?

2

Re: uninstall iRedMail

ve3lst wrote:

==== Required information ====
- iRedMail version (check /etc/iredmail-release):
- Linux/BSD distribution name and version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Web server (Apache or Nginx):
- Manage mail accounts with iRedAdmin-Pro?
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
======== Required information ====
- iRedMail version (check /etc/iredmail-release):
- Linux/BSD distribution name and version: ubuntu 16.04 LTS
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Web server (Apache or Nginx): apache
- Manage mail accounts with iRedAdmin-Pro?
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Hi,

I'd like to uninstall iRedMail completely, and reinstall it later on.
The problem when i try to download the script mentioned in this post
How to uninstall iRedMail it gives me "ERROR 404: Not Found."

what should i do?


I think that you should re-install server completly to remove iredmail

3

Re: uninstall iRedMail

what kind of "software" is this if it makes you have to reinstall your entire server... redicilous.

4

Re: uninstall iRedMail

iRedMail is designed to be deployed on a fresh/new/clean server, this way we can achieve best success for installation, otherwise we have to deal with a lot exceptions like "i have Apache installed, iRedMail installer doesn't detect and use it and it installs Nginx", " i have nextCloud running, iRedMail installer overrides my Nginx config", ...

You can remove the software binary packages installed by iRedMail manually, also their config files and data. It's too risk to remove by a script without confirm one-by-one. Incorrectly removing any data will cause more trouble.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

5

Re: uninstall iRedMail

imperiatos wrote:

what kind of "software" is this if it makes you have to reinstall your entire server... redicilous.

iRedMail is not the traditional "software", it's a solution which installs and configures many softwares for you. you can not simply remove one software as complete uninstall.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

6 (edited by elextro 2019-11-11 17:04:27)

Re: uninstall iRedMail

wow mr bunch of shit iredmail installs on ubuntu why not just tell them ???

dirmngr
dialog
postfix
postfix-pcre
libsasl2-modules
mysql-client
mysql-server
pos


log
Start-Date: 2019-11-09  17:38:08
Commandline: apt-get install -y dirmngr
Install: libksba8:amd64 (1.3.3-1ubuntu0.16.04.1, automatic), dirmngr:amd64 (2.1.11-6ubuntu2.1), libnpth0:amd64 (1.2-3, automatic)
End-Date: 2019-11-09  17:38:15

Start-Date: 2019-11-09  17:38:36
Commandline: apt-get install -y dialog
Install: dialog:amd64 (1.3-20160209-1)
End-Date: 2019-11-09  17:38:38

Start-Date: 2019-11-09  17:43:57
Commandline: apt-get install -y postfix postfix-pcre libsasl2-modules mysql-client mysql-server postfix-mysql libdbd-mysql-perl php-cli php-fpm php-json php-gd php-curl mcrypt php-intl php-xml php-mbstring php-mcrypt php-mysql nginx-full dovecot-imapd dovecot-pop3d dovecot-lmtpd dovecot-managesieved dovecot-sieve dovecot-mysql amavisd-new libcrypt-openssl-rsa-perl libmail-dkim-perl clamav-freshclam clamav-daemon spamassassin altermime arj nomarch cpio lzop cabextract p7zip-full rpm ripole libmail-spf-perl unrar-free pax lrzip mlmmj python-sqlalchemy python-dnspython python-mysqldb python-pymysql python-jinja2 python-netifaces python-webpy python-beautifulsoup python-lxml python-pycurl python-requests uwsgi uwsgi-plugin-python python-bcrypt fail2ban zlib1g libuuid1 libmnl0 curl lm-sensors netcat bzip2 acl patch cron tofrodos logwatch unzip bsdutils liblz4-tool
Install: libmpc3:amd64 (1.0.3-1, automatic), python-six:amd64 (1.10.0-3, automatic), libmpx0:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libnet-libidn-perl:amd64 (0.12.ds-2build2, automatic), python-sqlalchemy:amd64 (1.0.11+ds1-1ubuntu2), altermime:amd64 (0.3.10-7), librpmsign3:amd64 (4.12.0.1+dfsg1-3build3, automatic), libgcc-5-dev:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), rpm2cpio:amd64 (4.12.0.1+dfsg1-3build3, automatic), php-gd:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), python-pymysql:amd64 (0.7.2-1ubuntu1), postfix-pcre:amd64 (3.1.0-3ubuntu0.3), gnustep-common:amd64 (2.6.6-3, automatic), python-openssl:amd64 (0.15.1-2ubuntu0.2, automatic), spamassassin:amd64 (3.4.2-0ubuntu0.16.04.1), libauthen-sasl-perl:amd64 (2.1600-1, automatic), php-xml:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), libexttextcat-data:amd64 (3.4.4-1ubuntu3, automatic), libunix-syslog-perl:amd64 (1.1-2build7, automatic), libnet-ssleay-perl:amd64 (1.72-1build1, automatic), linux-libc-dev:amd64 (4.4.0-166.195, automatic), libnss3-nssdb:amd64 (2:3.28.4-0ubuntu0.16.04.6, automatic), postfix-mysql:amd64 (3.1.0-3ubuntu0.3), logwatch:amd64 (7.4.2-1ubuntu1), python-markupsafe:amd64 (0.23-2build2, automatic), libnorm1:amd64 (1.5r6+dfsg1-6+ubuntu16.04.1+deb.sury.org+1, automatic), libc6-dev:amd64 (2.23-0ubuntu11, automatic), mlmmj:amd64 (1.2.18.1-1ubuntu1), python-pycurl:amd64 (7.43.0-1ubuntu1), unrar-free:amd64 (1:0.0.1+cvs20140707-4~build0.16.04.1), whois:amd64 (5.2.11, automatic), python-dnspython:amd64 (1.12.0-1), libarchive-zip-perl:amd64 (1.56-2ubuntu0.1, automatic), python-requests:amd64 (2.9.1-3ubuntu0.1), libpgm-5.2-0:amd64 (5.2.122~dfsg-2+deb.sury.org~xenial+1, automatic), re2c:amd64 (0.16-1, automatic), arj:amd64 (3.10.22-14), libdate-manip-perl:amd64 (6.52-1, automatic), librpmbuild3:amd64 (4.12.0.1+dfsg1-3build3, automatic), libzmq5:amd64 (4.3.1-5+ubuntu16.04.1+deb.sury.org+1, automatic), libobjc4:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), dovecot-lmtpd:amd64 (1:2.2.22-1ubuntu2.12), dovecot-mysql:amd64 (1:2.2.22-1ubuntu2.12), cpp-5:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libdbi-perl:amd64 (1.634-1build1, automatic), lrzip:amd64 (0.621-1), python-netifaces:amd64 (0.10.4-0.1build2), cpp:amd64 (4:5.3.1-1ubuntu1, automatic), mysql-client:amd64 (5.7.27-0ubuntu0.16.04.1), libexttextcat-2.0-0:amd64 (3.4.4-1ubuntu3, automatic), libnetaddr-ip-perl:amd64 (4.078+dfsg-1build1, automatic), libarchive13:amd64 (3.1.2-11ubuntu0.16.04.7, automatic), libitm1:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libconvert-tnef-perl:amd64 (0.18-1, automatic), debugedit:amd64 (4.12.0.1+dfsg1-3build3, automatic), tofrodos:amd64 (1.7.13+ds-2ubuntu1), libnet-dns-perl:amd64 (0.81-2build1, automatic), gcc:amd64 (4:5.3.1-1ubuntu1, automatic), fail2ban:amd64 (0.9.3-1), libcilkrts5:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), python-chardet:amd64 (2.3.0-2, automatic), libio-socket-inet6-perl:amd64 (2.72-2, automatic), dovecot-imapd:amd64 (1:2.2.22-1ubuntu2.12), libasan2:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libmime-tools-perl:amd64 (5.507-1, automatic), python-cheetah:amd64 (2.4.4-3.fakesyncbuild1, automatic), libquadmath0:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libwavpack1:amd64 (4.75.2-2ubuntu0.2, automatic), python-lxml:amd64 (3.5.0-1ubuntu0.1), libmatheval1:amd64 (1.1.11+dfsg-2, automatic), dovecot-sieve:amd64 (1:2.2.22-1ubuntu2.12), lzop:amd64 (1.03-3.2), libisl15:amd64 (0.16.1-1, automatic), python-enum34:amd64 (1.1.2-1, automatic), nginx-common:amd64 (1.10.3-0ubuntu0.16.04.4, automatic), python-beautifulsoup:amd64 (3.2.1-1), libnet-cidr-perl:amd64 (0.17-1, automatic), libnet-smtp-ssl-perl:amd64 (1.03-1, automatic), libnet-server-perl:amd64 (2.008-2, automatic), dovecot-pop3d:amd64 (1:2.2.22-1ubuntu2.12), libio-socket-ssl-perl:amd64 (2.024-1, automatic), libmail-spf-perl:amd64 (2.9.0-4), libconvert-binhex-perl:amd64 (1.125-1, automatic), python3-pyinotify:amd64 (0.9.6-0fakesync1, automatic), python-ndg-httpsclient:amd64 (0.4.0-3, automatic), uwsgi-plugin-python:amd64 (2.0.12-5ubuntu3.2), librpmio3:amd64 (4.12.0.1+dfsg1-3build3, automatic), php-json:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), python-cryptography:amd64 (1.2.3-1ubuntu0.2, automatic), ntpdate:amd64 (1:4.2.8p4+dfsg-3ubuntu5.9, automatic), nginx-full:amd64 (1.10.3-0ubuntu0.16.04.4), amavisd-new:amd64 (1:2.10.1-2ubuntu1), pax:amd64 (1:20151013-1), rpm-common:amd64 (4.12.0.1+dfsg1-3build3, automatic), libio-multiplex-perl:amd64 (1.16-1, automatic), python-cffi-backend:amd64 (1.5.2-1ubuntu1, automatic), python-ipaddress:amd64 (1.0.16-1, automatic), libtsan0:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), php-curl:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), dovecot-core:amd64 (1:2.2.22-1ubuntu2.12, automatic), p7zip-full:amd64 (9.20.1~dfsg.1-4.2ubuntu0.1), libubsan0:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libberkeleydb-perl:amd64 (0.55-1build1, automatic), python-bcrypt:amd64 (2.0.0-2build1), unar:amd64 (1.9.1-1, automatic), python-jinja2:amd64 (2.8-1ubuntu0.1), rpm:amd64 (4.12.0.1+dfsg1-3build3), uwsgi-core:amd64 (2.0.12-5ubuntu3.2, automatic), libmail-dkim-perl:amd64 (0.40-1), librpm3:amd64 (4.12.0.1+dfsg1-3build3, automatic), make:amd64 (4.1-6, automatic), gcc-5:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libio-stringy-perl:amd64 (2.110-5, automatic), dovecot-managesieved:amd64 (1:2.2.22-1ubuntu2.12), python-pkg-resources:amd64 (20.7.0-1, automatic), python-html5lib:amd64 (0.999-4, automatic), libmailtools-perl:amd64 (2.13-1, automatic), php7.3-fpm:amd64 (7.3.11-1+ubuntu16.04.1+deb.sury.org+1, automatic), spamc:amd64 (3.4.2-0ubuntu0.16.04.1, automatic), liblz4-tool:amd64 (0.0~r131-2ubuntu2), php-cli:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), php-intl:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), python-urllib3:amd64 (1.13.1-2ubuntu0.16.04.3, automatic), clamav:amd64 (0.101.4+dfsg-0ubuntu0.16.04.1, automatic), python-webpy:amd64 (1:0.37+20120626-1), libgnustep-base1.24:amd64 (1.24.7-1build2, automatic), python-bs4:amd64 (4.4.1-1, automatic), libcrypt-openssl-rsa-perl:amd64 (0.28-2build2), liblua5.2-0:amd64 (5.2.4-1ubuntu1, automatic), liblsan0:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libgomp1:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libcrypt-openssl-bignum-perl:amd64 (0.06-1build1, automatic), clamav-daemon:amd64 (0.101.4+dfsg-0ubuntu0.16.04.1), libconvert-uulib-perl:amd64 (1:1.4~dfsg-1build5, automatic), clamdscan:amd64 (0.101.4+dfsg-0ubuntu0.16.04.1, automatic), clamav-freshclam:amd64 (0.101.4+dfsg-0ubuntu0.16.04.1), nomarch:amd64 (1.4-3), python-pyasn1:amd64 (0.1.9-1, automatic), php-fpm:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), libmhash2:amd64 (0.9.9.9-7, automatic), sa-compile:amd64 (3.4.2-0ubuntu0.16.04.1, automatic), gnustep-base-runtime:amd64 (1.24.7-1build2, automatic), manpages-dev:amd64 (4.04-2, automatic), php-mbstring:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), libsocket6-perl:amd64 (0.25-1build2, automatic), gnustep-base-common:amd64 (1.24.7-1build2, automatic), cabextract:amd64 (1.6-1), libdbd-mysql-perl:amd64 (4.033-1ubuntu0.1), libc-dev-bin:amd64 (2.23-0ubuntu11, automatic), libdigest-hmac-perl:amd64 (1.03+dfsg-1, automatic), libnss3:amd64 (2:3.28.4-0ubuntu0.16.04.6, automatic), lm-sensors:amd64 (1:3.4.0-2), ripole:amd64 (0.2.0+20081101.0215-1), netcat:amd64 (1.10-41), python-mysqldb:amd64 (1.3.7-1build2), clamav-base:amd64 (0.101.4+dfsg-0ubuntu0.16.04.1, automatic), netcat-traditional:amd64 (1.10-41, automatic), python-idna:amd64 (2.0-3, automatic), libclamav9:amd64 (0.101.4+dfsg-0ubuntu0.16.04.1, automatic), libatomic1:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libcc1-0:amd64 (5.4.0-6ubuntu1~16.04.12, automatic), libjansson4:amd64 (2.7-3ubuntu0.1, automatic), libyaml-0-2:amd64 (0.1.6-3, automatic), python-flup:amd64 (1.0.2-5, automatic), php-mysql:amd64 (2:7.3+70+ubuntu16.04.1+deb.sury.org+6), python-sqlalchemy-ext:amd64 (1.0.11+ds1-1ubuntu2, automatic), libllvm3.6v5:amd64 (1:3.6.2-3ubuntu2, automatic), libsys-hostname-long-perl:amd64 (1.5-1, automatic), libnet-ip-perl:amd64 (1.26-1, automatic), libnspr4:amd64 (2:4.13.1-0ubuntu0.16.04.1, automatic), uwsgi:amd64 (2.0.12-5ubuntu3.2), mcrypt:amd64 (2.6.8-1.3ubuntu1)
Remove: courier-imap:amd64 (4.10.0-20120615-1ubuntu7), courier-pop:amd64 (0.68.2-1ubuntu7)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2019-11-09  17:46:32

could you be polite and explain why does youre script creates new users and groups??

Removing user `amavis' ...


thank god i dont use nginx and could install all of this

7

Re: uninstall iRedMail

They're mostly dependent packages of the ones installed by iRedMail.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee