1 (edited by cmancilla 2019-08-07 05:31:33)

Topic: I dont receive or send mail after reboot Centos 7.6

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release):  0.9.9
- Deployed with iRedMail Easy or the downloadable installer?
- Linux/BSD distribution name and version: centos 7.6.1810
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): PGSQL
- Web server (Apache or Nginx):Nginx
- Manage mail accounts with iRedAdmin-Pro?
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

after restarting 100% cpu busy centers

systemctl status amavisd.service -l
● amavisd.service - Amavisd-new is an interface between MTA and content checkers.
   Loaded: loaded (/usr/lib/systemd/system/amavisd.service; enabled; vendor preset: disabled)
   Active: active (running) since mar 2019-08-06 17:27:02 -04; 7s ago
     Docs: http://www.ijs.si/software/amavisd/#doc
  Process: 5387 ExecStart=/usr/sbin/amavisd -c /etc/amavisd/amavisd.conf (code=exited, status=0/SUCCESS)
Main PID: 5420 (/usr/sbin/amavi)
    Tasks: 13
   CGroup: /system.slice/amavisd.service
           ├─5420 /usr/sbin/amavisd (master
           ├─5436 /usr/sbin/amavisd (ch1-05436-01
           ├─5437 /usr/sbin/amavisd (virgin child
           ├─5438 /usr/sbin/amavisd (virgin child
           ├─5439 /usr/sbin/amavisd (virgin child
           ├─5440 /usr/sbin/amavisd (virgin child
           ├─5441 /usr/sbin/amavisd (virgin child
           ├─5442 /usr/sbin/amavisd (virgin child
           ├─5443 /usr/sbin/amavisd (virgin child
           ├─5444 /usr/sbin/amavisd (virgin child
           ├─5445 /usr/sbin/amavisd (virgin child
           ├─5446 /usr/sbin/amavisd (virgin child
           └─5447 /usr/sbin/amavisd (virgin child

ago 06 17:27:02 mail.incancer.cl amavis[5420]: Net::Server: Group Not Defined.  Defaulting to EGID '973 973'
ago 06 17:27:02 mail.incancer.cl amavis[5420]: Net::Server: User Not Defined.  Defaulting to EUID '980'
ago 06 17:27:02 mail.incancer.cl amavis[5420]: No ext program for   .lrz, tried: lrzip -q -k -d -o -, lrzcat -q -k
ago 06 17:27:02 mail.incancer.cl amavis[5420]: No decoder for       .lrz
ago 06 17:27:02 mail.incancer.cl amavis[5420]: Using primary internal av scanner code for clamav-socket
ago 06 17:27:02 mail.incancer.cl amavis[5420]: Found secondary av scanner clamav-clamscan at /usr/bin/clamscan
ago 06 17:27:02 mail.incancer.cl systemd[1]: Started Amavisd-new is an interface between MTA and content checkers..
ago 06 17:27:06 mail.incancer.cl amavis[5436]: (05436-01) (!)connect to /var/run/clamd.amavisd/clamd.socket failed, attempt #1: Can't connect to a UNIX socket /var/run/clamd.amavisd/clamd.socket: Permiso denegado
ago 06 17:27:07 mail.incancer.cl amavis[5436]: (05436-01) (!)connect to /var/run/clamd.amavisd/clamd.socket failed, attempt #1: Can't connect to a UNIX socket /var/run/clamd.amavisd/clamd.socket: Permiso denegado
ago 06 17:27:07 mail.incancer.cl amavis[5436]: (05436-01) (!)clamav-socket: All attempts (1) failed connecting to /var/run/clamd.amavisd/clamd.socket, retrying (2)

2

Re: I dont receive or send mail after reboot Centos 7.6

what,


I need help, I have my institution without mail

please

3

Re: I dont receive or send mail after reboot Centos 7.6

Try this:

- Open file /etc/amavisd/amavisd.conf, find line below:

@bypass_virus_checks_maps = (0);

Replace "(0)" by "1" (without quotes), then restart Amavisd service.
- Put all emails in queue to HOLD:

postsuper -h ALL

- Kill all "clamscan" processes with command:

pkill -9 clamscan

- Start clamd service:

service clamd@amavisd restart

- Re-enable virus scanning in /etc/amavisd/amavisd.conf with setting below:

@bypass_virus_checks_maps = (0);

- Re-queue all hold message for delivery:

postsuper -H ALL

BTW, i fixes same issue for 2 clients in passed week, i guess there's something wrong with clamav or its virus signature database... it becomes more memory hungry.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

4

Re: I dont receive or send mail after reboot Centos 7.6

UPDATE on this issue:

If server has 4GB or even less memory, ClamAV starts slowly and takes a long
time. It may exceed systemd default timeout setting and considered as failed
to start.
We need to increase the timeout value to avoid this issue. Steps:

*) Create new directory:

- on CentOS: /etc/systemd/system/clamd@amavisd.service.d/
- on Debian/Ubuntu: /etc/systemd/system/clamav-daemon.service.d/

*) Create file "override.conf" with content below under this new directory:

[Service]
TimeoutSec = 600

*) Run "systemctl daemon-reload".

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

5 (edited by srosoftware 2019-09-20 23:18:34)

Re: I dont receive or send mail after reboot Centos 7.6

Thanks for posting this.  We had this issue on a Centos VM (w 8GB allocated) immediately after a rebooting for security updates this morning:

Sep 19 06:39:23 m1 systemd: clamd@amavisd.service start operation timed out. Terminating.
Sep 19 06:39:23 m1 systemd: Failed to start clamd scanner (amavisd) daemon.

I haven't taken the time to poke around, but it's likely the latest version of the clamd daemon is taking a lot longer to start regardless of memory.

ClamAV 0.101.4/25577/Thu Sep 19 01:20:13 2019
CentOS Linux release 7.7.1908

ZhangHuangbin wrote:

UPDATE on this issue:

If server has 4GB or even less memory, ClamAV starts slowly and takes a long
time. It may exceed systemd default timeout setting and considered as failed
to start.
We need to increase the timeout value to avoid this issue. Steps:

*) Create new directory:

- on CentOS: /etc/systemd/system/clamd@amavisd.service.d/
- on Debian/Ubuntu: /etc/systemd/system/clamav-daemon.service.d/

*) Create file "override.conf" with content below under this new directory:

[Service]
TimeoutSec = 600

*) Run "systemctl daemon-reload".

6

Re: I dont receive or send mail after reboot Centos 7.6

srosoftware wrote:

I haven't taken the time to poke around, but it's likely the latest version of the clamd daemon is taking a lot longer to start regardless of memory.

Did you update /etc/systemd/system/clamd@amavisd.service.d/override.conf?

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee