1

Topic: Key length error exceeding 767 with iRedAPD and iRedAdmin upgrades

When I was upgrading iRedAPD and iRedAdmin, they both run SQL scripts.  Given I have MariaDB installed, you need to add some specific innoDB settings to your conf 50-server.cnf file.

Under the InnoDB section (which is probably empty) add the following lines so it looks like this:


#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# ADDED to FIX MAX KEY LENGTH ISSUE FOR IREDADMIN/IREDAPD
innodb_file_format = Barracuda
innodb_file_per_table = on
innodb_default_row_format = dynamic
innodb_large_prefix = 1
innodb_file_format_max = Barracuda

This then fixes the key length error encountered when adding new tables (which was needed in my case when I graded from an older version)

good luck.

2

Re: Key length error exceeding 767 with iRedAPD and iRedAdmin upgrades

Thanks for sharing. smile

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee