1 (edited by wimvandijck 2020-03-22 14:27:41)

Topic: FreeBSD fresh install fails - python 2 vs 3 conflict

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release):  git master
- Deployed with iRedMail Easy or the downloadable installer? installer
- Linux/BSD distribution name and version: FreeBSD 12.1-RELEASE-p2
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? no
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

===>  Installing for py27-setuptools-44.0.0
===>  Checking if py27-setuptools is already installed
===>   Registering installation for py27-setuptools-44.0.0 as automatic
Installing py27-setuptools-44.0.0...
pkg-static: py27-setuptools-44.0.0 conflicts with py37-setuptools-41.4.0_1 (installs files into the same place).  Problematic file: /usr/local/bin/easy_install
*** Error code 70

Stop.
make[1]: stopped in /usr/ports/devel/py-setuptools
*** Error code 1
root@mail2:~/iRedMail-master # cat /etc/make.conf
# iRedMail-WANT_OPENLDAP_VER
WANT_OPENLDAP_VER=24
# iRedMail-WANT_PGSQL_VER
WANT_PGSQL_VER=12
# iRedMail-WANT_BDB_VER
WANT_BDB_VER=5
# iRedMail-DEFAULT_VERSIONS
DEFAULT_VERSIONS=ssl=libressl python=2.7 python2=2.7 python3=3.8 pgsql=12 php=7.4
# iRedMail-OPTIONS_SET-SASL
OPTIONS_SET+=SASL
# iRedMail-OPTIONS_UNSET-X11
OPTIONS_UNSET+=X11
# iRedMail-LICENSES_ACCEPTED-DCC
LICENSES_ACCEPTED+=DCC

It seems both python 2.7 as 3.7 get pulled in. Can we avoid having 2.7?
This is a freshly installed machine.
Using AWS AMI, so can easily reinstall and reproduce.

Kindest regards,
Wim

2

Re: FreeBSD fresh install fails - python 2 vs 3 conflict

Still few programs require py2 (iredapd, mlmmjadmin, iredadmin and iRedAdmin-Pro). It takes time to port to py3, we still need py2 at this stage.

iRedMail installer should install both py 2.7 and 3.8, and I didn’t have such conflict while testing. Does the AMI have some pre-installed packages before iRedMail installation?

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

3

Re: FreeBSD fresh install fails - python 2 vs 3 conflict

You were correct, the AMI came with several py3 packages to support aws-cli. Once I removed those, the installer ran successfully. Thanks!