1

Topic: Mail installation on ubuntu20.04.0

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release):
- Deployed with iRedMail Easy or the downloadable installer?
- Linux/BSD distribution name and version:
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):
- Web server (Apache or Nginx):
- Manage mail accounts with iRedAdmin-Pro?
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

The following packages have unmet dependencies:
mariadb-server : Depends: mariadb-server-10.3 (>= 1:10.3.25-0ubuntu0.20.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
<< ERROR >> Installation failed, please check the terminal output.
<< ERROR >> If you're not sure what the problem is, try to get help in iRedMail
<< ERROR >> forum: https://forum.iredmail.org/

I've tried to install iRedMail-1.3.2 on my vps using ubuntu 20 as my OS, but I keep getting this error.

2

Re: Mail installation on ubuntu20.04.0

Please try to update server OS to the latest release first, then run iRedMail installer again.

apt update
apt upgrade

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

3

Re: Mail installation on ubuntu20.04.0

ZhangHuangbin wrote:

Please try to update server OS to the latest release first, then run iRedMail installer again.

apt update
apt upgrade

I already did that but I still got the error.

4

Re: Mail installation on ubuntu20.04.0

Try to install package "mariadb-server" manually, any error on console? Could you manage to fix the error?

apt install mariadb-server

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee