1

Topic: Fresh install crash

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.4.1
- Deployed with iRedMail Easy or the downloadable installer? YES
- Linux/BSD distribution name and version:  DEBIAN 10/11
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): PGSQL
- Web server (Apache or Nginx): nginx
- Manage mail accounts with iRedAdmin-Pro? NO
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====


E: Unable to locate package sogo-activesync
E: Unable to locate package sope4.9-gdl1-postgresql
E: Couldn't find any package by glob 'sope4.9-gdl1-postgresql'
E: Couldn't find any package by regex 'sope4.9-gdl1-postgresql'



Regards,

2

Re: Fresh install crash

=== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.4.1
- Deployed with iRedMail Easy or the downloadable installer? downloadable
- Linux/BSD distribution name and version:  Rocky Linux 8
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): (intent) MySQL
- Web server (Apache or Nginx): nginx
- Manage mail accounts with iRedAdmin-Pro? NO
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====
I just crashed out too. Minimal Rocky Linux 8

[ INFO ] Preparing yum repositories ...
[ INFO ] Installing package(s): epel-release dnf-plugins-core
No repository match: remi
No repository match: remi-php74
No repository match: ius
No repository match: rpmforge
No repository match: atrpms
No repository match: remi-safe
Last metadata expiration check: 0:05:15 ago on Sun Sep 12 19:44:45 2021.
Package epel-release-8-10.el8.noarch is already installed.
Package dnf-plugins-core-4.0.18-4.el8.noarch is already installed.
Dependencies resolved.
================================================================================================================================================================================
Package                                       Architecture                            Version                                      Repository                             Size
================================================================================================================================================================================
Upgrading:
epel-release                                  noarch                                  8-11.el8                                     epel                                   23 k

Transaction Summary
================================================================================================================================================================================
Upgrade  1 Package

Total download size: 23 k
Downloading Packages:
epel-release-8-11.el8.noarch.rpm                                                                                                                 75 kB/s |  23 kB     00:00
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                            47 kB/s |  23 kB     00:00
warning: /var/cache/dnf/epel-2f52d25564da0fd7/packages/epel-release-8-11.el8.noarch.rpm: Header V4 RSA/SHA256 Signature, key ID 2f86d6a1: NOKEY
Extra Packages for Enterprise Linux 8 - x86_64                                                                                                  1.6 MB/s | 1.6 kB     00:00
Importing GPG key 0x2F86D6A1:
Userid     : "Fedora EPEL (8) <epel@fedoraproject.org>"
Fingerprint: 94E2 79EB 8D8F 25B2 1810 ADF1 21EA 45AB 2F86 D6A1
From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-8
Key imported successfully
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                        1/1
  Running scriptlet: epel-release-8-11.el8.noarch                                                                                                                           1/1
  Upgrading        : epel-release-8-11.el8.noarch                                                                                                                           1/2
  Cleanup          : epel-release-8-10.el8.noarch                                                                                                                           2/2
  Running scriptlet: epel-release-8-10.el8.noarch                                                                                                                           2/2
  Verifying        : epel-release-8-11.el8.noarch                                                                                                                           1/2
  Verifying        : epel-release-8-10.el8.noarch                                                                                                                           2/2

Upgraded:
  epel-release-8-11.el8.noarch

Complete!
[ INFO ] Enable yum repos: appstream, powertools.
[ INFO ] Fetching source tarballs ...
[ INFO ] + 1 of 5: https://dl.iredmail.org/yum/misc/iRedAdmin-1.5.tar.gz
[ INFO ] + 2 of 5: https://dl.iredmail.org/yum/misc/mlmmja … 1.2.tar.gz
[ INFO ] + 3 of 5: https://dl.iredmail.org/yum/misc/iRedAPD-5.0.3.tar.gz
[ INFO ] + 4 of 5: https://dl.iredmail.org/yum/misc/netdata-v1.31.0.gz.run
[ INFO ] + 5 of 5: https://dl.iredmail.org/yum/misc/roundc … ete.tar.gz
[ INFO ] Validate downloaded source tarballs ...
sha256sum: misc/iRedAdmin-1.5.tar.gz: No such file or directory
misc/iRedAdmin-1.5.tar.gz: FAILED open or read
sha256sum: misc/mlmmjadmin-3.1.2.tar.gz: No such file or directory
misc/mlmmjadmin-3.1.2.tar.gz: FAILED open or read
sha256sum: misc/iRedAPD-5.0.3.tar.gz: No such file or directory
misc/iRedAPD-5.0.3.tar.gz: FAILED open or read
sha256sum: misc/netdata-v1.31.0.gz.run: No such file or directory
misc/netdata-v1.31.0.gz.run: FAILED open or read
sha256sum: misc/roundcubemail-1.4.11-complete.tar.gz: No such file or directory
misc/roundcubemail-1.4.11-complete.tar.gz: FAILED open or read
sha256sum: WARNING: 5 listed files could not be read
        [ FAILED ]
<< ERROR >> Package verification failed. Script exit ...







warbot wrote:

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.4.1
- Deployed with iRedMail Easy or the downloadable installer? YES
- Linux/BSD distribution name and version:  DEBIAN 10/11
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): PGSQL
- Web server (Apache or Nginx): nginx
- Manage mail accounts with iRedAdmin-Pro? NO
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====


E: Unable to locate package sogo-activesync
E: Unable to locate package sope4.9-gdl1-postgresql
E: Couldn't find any package by glob 'sope4.9-gdl1-postgresql'
E: Couldn't find any package by regex 'sope4.9-gdl1-postgresql'



Regards,

3

Re: Fresh install crash

Rocky Linux 8 Install as above.

I did it a second time and it continued where it left off and finished the script without error.

I made it to reboot message.

Solution: Run a second time. Script picks right up where it left off.

4

Re: Fresh install crash

montanelli wrote:

Solution: Run a second time. Script picks right up where it left off.

Your issue is the installer failed to download packages. Don't make it a mysterious thing.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

5

Re: Fresh install crash

warbot wrote:

E: Unable to locate package sogo-activesync

SOGo team doesn't offer binary packages for Debian 11 yet.
FYI: https://www.sogo.nu/bugs/view.php?id=5380

Leave a reply in the bug tracker, let SOGO developers know you need Debian 11 support.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

6

Re: Fresh install crash

Hi,

I started with buster and received the same error at install. Then i upgraded to bullseye.


Regards,



ZhangHuangbin wrote:
warbot wrote:

E: Unable to locate package sogo-activesync

SOGo team doesn't offer binary packages for Debian 11 yet.
FYI: https://www.sogo.nu/bugs/view.php?id=5380

Leave a reply in the bug tracker, let SOGO developers know you need Debian 11 support.

7 (edited by warbot 2021-09-13 20:49:42)

Re: Fresh install crash

Hi,

FYI




ZhangHuangbin wrote:
warbot wrote:

E: Unable to locate package sogo-activesync

SOGo team doesn't offer binary packages for Debian 11 yet.
FYI: https://www.sogo.nu/bugs/view.php?id=5380

Leave a reply in the bug tracker, let SOGO developers know you need Debian 11 support.

Post's attachments

iredmail.png
iredmail.png 144.78 kb, 1 downloads since 2021-09-13 

You don't have the permssions to download the attachments of this post.

8

Re: Fresh install crash

Any error on console after you run the iRedMail installer?
Seems iRedMail installer failed to install package "dirmngr", which causes missing "gnupg" package (dependent package) and failed to import apt key for SOGO repository.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

9 (edited by cvcvelo 2021-09-30 06:34:42)

Re: Fresh install crash

warbot wrote:

Hi,

FYI




ZhangHuangbin wrote:
warbot wrote:

E: Unable to locate package sogo-activesync

SOGo team doesn't offer binary packages for Debian 11 yet.
FYI: https://www.sogo.nu/bugs/view.php?id=5380

Leave a reply in the bug tracker, let SOGO developers know you need Debian 11 support.

I left a note a few weeks ago, thanks.

The Debian bullseye package repository now includes a SOGo 5.0.1-4 binary package:

https://packages.debian.org/stable/mail/sogo

Does this mean it is now safe to upgrade an iRedMail server from Debian 10 to Debian 11?

One other issue: My server has SOGo v. 5.2.0.20210928-1 from the nightly builds, and obviously 5.0.1-4 is older than that.

If it is OK to upgrade to Debian 11, is the recommended path to add SOGo from the bullseye repository and then roll forward to the nightly builds? Or something else?

I would like to upgrade if possible, especially to use the newer kernel which fixes several current security vulnerabilities. Thanks!

10

Re: Fresh install crash

I didn't test the one offered in Debian official apt repo, sorry.
in the meantime, could you help leave a reply in SOGo bug tracker to let SOGo developers know Debian 11 users need some love from them:
https://www.sogo.nu/bugs/view.php?id=5380

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

11

Re: Fresh install crash

Thanks @zhb. I left a note there on 25 September, and have been checking the Inverse nightly updates repository since then, but no news so far.

I encourage @warbot and all other Debian users to file requests for a nightly build that will run on Debian bullseye. Thanks!