1

Topic: Change domain name for Roundcube and Sogo

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.0 MARIADB EDITION
- Deployed with iRedMail Easy or the downloadable installer? INSTALLER
- Linux/BSD distribution name and version: UBUNTI 20.04
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MARIADB
- Web server (Apache or Nginx): NGINX
- Manage mail accounts with iRedAdmin-Pro? NO
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

I had this server running without any problems, and it hosted a domain, say, MYPRIVATE.DE.
Now, I'd like to use that very server for my other domain MYOTHER.DE - and only for that.

I deleted the old domain with iredadmin, created the new one, and the server itself works fine: IMAP & SMTP work, and I can log in to ROUNDCUBE and to SOGO from my internal net via MYSERVER/MAIL.

I can't, however, log in "from the outside", and I assume this has to do with the fact that the "web server" I am addressing has changed its name. Or rather, I am "coming in" with another URL, namely MYOTHER.DE/MAIL - and the server seems to not deliver this webpage - simply as it doesn't "know it". What disturbs me is the fact that "00-default-ssl.conf" in my /etc/nginx/sites-enabled (and in sites-available as well) is more or less empty, in any case, it does NOT contain my old domain's name MYPRIVATE.DE. Do I understand something wrong? Or, what can I do to "repair" the situation Thanks in advance for any hints.

----

Spider Email Archiver: On-Premises, lightweight email archiving software developed by iRedMail team.

2

Re: Change domain name for Roundcube and Sogo

i guess, nginx uses the hostname from your server in default-ssl.conf

so, did you aswell change the hostname?

3 (edited by Emma2 2022-01-07 23:49:36)

Re: Change domain name for Roundcube and Sogo

Hi. Cthulhu (cool nick ;-)

No, I didn't change the hostname, but it wasn't identical with my external name earlier either. As an example:

My host is named "myserver", the earlier mail server was "myprivate.de", the one I want to use now is "myother.de".

My firewall routes HTTPS for the address "mail.myother.de" internally to the host "myserver".
Earlier, my firewall did so for "mail.myprivate.de", and this worked fine, and it even worked with "mail.myprivate.de/sogo".

Now, I can internally call "myserver/mail" and "myserver" (which is routed to the same), and I can call "myserver/sogo". The only problem is that there seems to be no "virtual host" (as it would be called on Apache) which answers to "myother.de".

On Apache, this would be described in "sites-available"and "sites-enabled", and I understood that to be the same on NGINX. However, I cannot find any such entry, even not for my old "virtual host" named "myprivate.de". The only occurances of "myprivate.de" I can find, reside in the /etc/amavis directory.

Do I understand something wrong in this description: https://www.linuxbabe.com/mail-server/s … ains-nginx

Ot, the other way around: As my NGINX only seems to listen as "server_name_" (which seems to resolve to the host name), why did it work earlier?

UPDATE:
I actually found the string "myprivate.de" only in three files in /etc:
/etc/amavis/conf.d/50-user, /etc/postfix/aliases, and /etc/dovecot/dovecot.conf - but they can't be the reason for my problem, or can they? If I call "https://mail.myother.de" I receive an error 503, and from my experience with Apache (which is not really so big), this seems to indicate that there is no virtual host for this URL.