1

Topic: Cannot deploy iRedMail on a fresh VPS

iRedMail version: 1.5.1
Deploy with downloadable installer
Ubuntu 20.04 LTS
MariaDB
Nginx

This is a fresh install of Ubuntu 20.04 on my newly purchased VPS, and I'm trying to deploy iRedMail on it. This is the error that I get in the terminal window:

 Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 mariadb-server : Depends: mariadb-server-10.3 (>= 1:10.3.32-0ubuntu0.20.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
<< ERROR >> Installation failed, please check the terminal output.
<< ERROR >> If you're not sure what the problem is, try to get help in iRedMail
<< ERROR >> forum: https://forum.iredmail.org/

I tried to reinstall Ubuntu on my machine and re-download the installer and try again but I get the same error.

----

Spider Email Archiver: On-Premises, lightweight email archiving software developed by iRedMail team. Stable release is out.

2

Re: Cannot deploy iRedMail on a fresh VPS

If you have not already updated the OS, please run apt-get update && apt-get upgrade -y before trying to install iRedMail. To me it looks like it's trying to install a version that is not available anymore and therefore fails to install.

3

Re: Cannot deploy iRedMail on a fresh VPS

alm wrote:

If you have not already updated the OS, please run apt-get update && apt-get upgrade -y before trying to install iRedMail. To me it looks like it's trying to install a version that is not available anymore and therefore fails to install.

I have tried already that and still no luck. Meanwhile I purchased a new VPS from a different company and I have the same error. It looks like iRedMail install is not up to date with the current packages in Ubuntu.

4

Re: Cannot deploy iRedMail on a fresh VPS

then install mariadb-server-10.3 manually and run install script again

5

Re: Cannot deploy iRedMail on a fresh VPS

After some investigation, installing mariadb on ubuntu is broken in some ways:

1)     default-mysql-client [1.0.5ubuntu2 (eoan, now)]   
2)     mysql-client-8.0 [8.0.17-0ubuntu2 (eoan, now)]     
3)     mysql-client-core-8.0 [8.0.17-0ubuntu2 (eoan, now)]
4)     mysql-server-8.0 [8.0.17-0ubuntu2 (eoan, now)]     
5)     mysql-server-core-8.0 [8.0.17-0ubuntu2 (eoan, now)]


those packages conflict

try;

apt purge *mysql*
apt-get update
aptitude install mariadb-server