Topic: Recipient address rejected: Intentional policy

- iRedMail version (check /etc/iredmail-release): 2.6.1
- Deployed with iRedMail Easy or the downloadable installer? No
- Linux/BSD distribution name and version: Ubuntu 20.04.4 LTS
- Store mail accounts in which backend (LDAP/MySQL/PGSQL):  MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? Yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.

Have been getting a few of these on critical emails.
Aug  1 15:39:02 server postfix/smtpd[528780]: NOQUEUE: reject: RCPT from mxr8.enom.com[]: 451 4.7.1 <myname@domain>: Recipient address rejected: Intentional policy rejection, please try again later; from=<donotreply@name-services.com> to=<myname@domain> proto=ESMTP helo=<mxr8.enom.com>. 

Tried entering @name-services.com in greylisting and whitelisting pages on iRedAdminPro - not much luck.
Also: reading through: Also tried /opt/iredapd/tools# ./greylisting_admin.py --disable --from '@name-services.com'

When I perform greylisting_admin.py --list

Status   Sender                             -> Local Account
disabled @name-services.com                 -> @. (anyone)
enabled  @. (anyone)                        -> @. (anyone)

Looks correct, is this the only way to whitelist @name-services.com  ?
Should I be able to perform this via iRedadminPro ?

Apologies, total novice in this area.



Spider Email Archiver: On-Premises, lightweight email archiving software developed by iRedMail team. Supports Amazon S3 compatible storage and custom branding.


Re: Recipient address rejected: Intentional policy

You can manage global, per-domain and per-user greylisting settings in iRedAdmin-Pro.

- global: go to "Settings" -> Greylisting.
- per domain and per-user settings: go to account profile page, tab "Greylisting".


Re: Recipient address rejected: Intentional policy

Thanks, Zhang, I "Think" did enter that initially  in global->Settings->Greylisting and it was still failing, may be due to some error on my part, 
eventually, ended up performing it via greylisting_admin.py, which worked.
Will remove the entry and re-apply into global as suggested and will monitor.