1 (edited by slovenka 2024-03-01 18:38:53)

Topic: Fresh install failed on AlmaLinux9 OpenLDAP

- iRedMail version (check /etc/iredmail-release): 1.6.8
- Deployed with iRedMail Easy or the downloadable installer? downloadable
- Linux/BSD distribution name and version: AlmaLinux 9
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? Not yet installed
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.

< Question > Continue? [y|N]y
--2024-02-27 12:48:32--  https://keys.openpgp.org/vks/v1/by-fingerprint/74FFC6D72B925A34B5D356BDF8A27B36A6E2EAE9
Loaded CA certificate '/etc/pki/tls/certs/ca-bundle.crt'
Resolving keys.openpgp.org (keys.openpgp.org)..., 2a00:c6c0:0:154:1::1
Connecting to keys.openpgp.org (keys.openpgp.org)||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3224 (3.1K) [application/pgp-keys]
Saving to: '/etc/pki/rpm-gpg/sogo-nightly'

/etc/pki/rpm-gpg/sogo-nightly                                                     100%[===========================================================================================================================================================================================================>]   3.15K  --.-KB/s    in 0s

2024-02-27 12:48:33 (25.4 MB/s) - '/etc/pki/rpm-gpg/sogo-nightly' saved [3224/3224]

[ INFO ] Add yum repo for SOGo: /etc/yum.repos.d/sogo.repo.
[ INFO ] Installing package(s): rsyslog firewalld python3 python3-pip python3-pip-wheel python3-requests uwsgi-logger-syslog uwsgi-plugin-python3 postfix cyrus-sasl cyrus-sasl-lib cyrus-sasl-plain postfix-pcre postfix-ldap openldap-servers openldap-clients mariadb-server perl-DBD-mysql python3-ldap php-cli php-common php-fpm php-gd php-xml php-mysqlnd php-ldap php-pgsql php-mbstring php-pecl-apcu php-intl php-json php-pecl-zip nginx dovecot dovecot-pigeonhole dovecot-mysql amavis spamassassin altermime perl-Mail-SPF lz4 clamav clamav-update clamav-server clamav-server-systemd mlmmj python3-ldap python3-PyMySQL sogo sogo-activesync libwbxml sogo-ealarms-notify sogo-tool sope49-gdl1-mysql sope49-ldap mysql-libs python3-sqlalchemy python3-setuptools python3-dns python3-six python3-ldap python3-PyMySQL python3-jinja2 python3-PyMySQL python3-dns python3-simplejson fail2ban curl libmnl libuuid lm_sensors nc zlib iproute python3-pyyaml unzip bzip2 acl patch tmpwatch crontabs dos2unix logwatch lz4
No repository match: ius
No repository match: atrpms
No repository match: rpmforge
No repository match: remi-safe
No repository match: remi
No repository match: remi-php74
AlmaLinux 9 - AppStream                         7.7 kB/s | 4.1 kB     00:00
AlmaLinux 9 - BaseOS                            7.4 kB/s | 3.8 kB     00:00
AlmaLinux 9 - CRB                               3.9 MB/s | 2.5 MB     00:00
AlmaLinux 9 - Extras                            8.7 kB/s | 3.8 kB     00:00
Extra Packages for Enterprise Linux 9 - Next -  1.6 MB/s | 1.4 MB     00:00
SOGo Groupware                                  117 kB/s |  79 kB     00:00
Package rsyslog-8.2102.0-117.el9.x86_64 is already installed.
Package firewalld-1.2.5-2.el9_3.noarch is already installed.
Package python3-3.9.18-1.el9_3.1.x86_64 is already installed.
Package python3-pip-wheel-21.2.3-7.el9.noarch is already installed.
Package cyrus-sasl-lib-2.1.27-21.el9.x86_64 is already installed.
Package python3-six-1.15.0-9.el9.noarch is already installed.
Package curl-7.76.1-26.el9_3.2.x86_64 is already installed.
Package libmnl-1.0.4-15.el9.x86_64 is already installed.
Package libuuid-2.37.4-15.el9.x86_64 is already installed.
Package zlib-1.2.11-40.el9.x86_64 is already installed.
Package iproute-6.2.0-5.el9.x86_64 is already installed.
Package unzip-6.0-56.el9.x86_64 is already installed.
Package acl-2.3.1-3.el9.x86_64 is already installed.
Package crontabs-1.11-27.20190603git.el9_0.noarch is already installed.
 Problem: cannot install the best candidate for the job
  - nothing provides openldap(x86-64) = 2.6.6 needed by openldap-servers-2.6.6-1.el9.next.x86_64 from epel-next
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
<< ERROR >> Installation failed, please check the terminal output.
<< ERROR >> If you're not sure what the problem is, try to get help in iRedMail
<< ERROR >> forum: https://forum.iredmail.org/


Spider Email Archiver: On-Premises, lightweight email archiving software developed by iRedMail team. Supports Amazon S3 compatible storage and custom branding.


Re: Fresh install failed on AlmaLinux9 OpenLDAP

Strange, reinstalled epel-release

dnf remove epel-release
dnf install epel-release

Now it works.

New error:

[ INFO ] Configure Amavisd-new (interface between MTA and content checkers).
ERROR 1133 (28000) at line 5: Can't find any matching row in the user table
[ INFO ] Configure SpamAssassin (content-based spam filter).
[ INFO ] Configure iRedAPD (postfix policy daemon).
ERROR 1133 (28000) at line 7: Can't find any matching row in the user table


Re: Fresh install failed on AlmaLinux9 OpenLDAP

Is above MySQL error problematic, or can we continue with deployment?
Thank you!


Re: Fresh install failed on AlmaLinux9 OpenLDAP

Above iRedMail installation failed.
The problem is i can not reproduce this issue locally with latest iRedMail.


Re: Fresh install failed on AlmaLinux9 OpenLDAP

Yup, my mistake, I missed this one:
"Do *NOT* use special characters (like $, white space) in password".

We want extra secure passwords, but nope. Bash messes things up.

Anyway, now it works with no errors. Still had to remove and reinstall epel-release tho.

Thank you for your time!

6 (edited by slovenka 2024-03-16 22:23:39)

Re: Fresh install failed on AlmaLinux9 OpenLDAP

Is this a bug? `epel-next-release` should not be installed on AlmaLinux. If I remove it, the installer downloads packages normally.

https://github.com/AlmaLinux/almalinux- … issues/184


Re: Fresh install failed on AlmaLinux9 OpenLDAP

I can reproduce this issue:

  - nothing provides openldap(x86-64) = 2.6.6 needed by openldap-servers-2.6.6-1.el9.next.x86_64 from epel-next

The problem is, epel-next offers openldap-server 2.6.6, but the client package offered by Alma9 base system is 2.6.3, and epel-next

# yum info openldap-servers
Version      : 2.6.6
Release      : 1.el9.next
Architecture : x86_64
Repository   : epel-next

# yum info openldap
Name         : openldap
Version      : 2.6.3
Release      : 1.el9
Architecture : x86_64

Repository   : @System


Re: Fresh install failed on AlmaLinux9 OpenLDAP

Updated iRedMail (locall), have to disable epel-next during iRedMail installation.
This fix will be available in next iRedMail release. Thanks for the feedback. smile