1 (edited by layer3guru 2026-09-22 10:32:26)

Topic: SSL Implementation Please Help

2026081001 (Backend: mariadb, Date: 2026-08-15 17:41:56) iRedMail Enterprise Edition

I purchased a ssl cert from namechep.com I recieved 3 files
.ca-bundle
.cert
.p7b
I tried to use to implement Use a bought SSL certificate from the documentation

Now I can't get anything to start this is the error in the nginx logs
1123#1123: cannot load certificate "/opt/iredmail/ssl/combined.pem": BIO_new_file() failed (SSL: error:80000002:system library::No such file or directory:calling fopen(/opt/iredmail/ssl/combined.pem, r) error:10000080:BIO routines::no such file)

I did follow the directions and create backups of the original files in /opt/iredmail/ssl/ to .bak. But when trying to copy the .bak files back to the originals then reboot I get the same errors error.

----

Spider Email Archiver: On-Premises, lightweight email archiving software developed by iRedMail team. Supports Amazon S3 compatible storage and custom branding.

2 (edited by layer3guru 2026-09-22 12:00:13)

Re: SSL Implementation Please Help

I figured this out. I am going to write a document I hope will be accepted for here on when working with namecheap how to make it happen. So please this thread open for a week or two while I perfect this.

3

Re: SSL Implementation Please Help

I hope this helps someone

Post's attachments

How to Install a Namecheap SSL Certificate on iRedMail Enterprise Running Ubuntu.pdf 99.98 kb, 1 downloads since 2026-09-26 

You don't have the permssions to download the attachments of this post.