1 (edited by wm 2011-05-14 18:42:11)

Topic: iRedMail-0.7.1 on Ubuntu 10.04 runs into postconf error


I've decided to move from manual postfix configuration (done following the workaround.org turorials) to iRedMail
I've tested the setup on VirtualBox instance first with no issues.

I then tried to repeat the setup on a real server. The main difference probably is the ssh server is pre-installed. But the image is also the minimal server (nothing on it other than the sshd).

when iRedMail came to the postfix setup it gets stuck not finding the main.cf file:

postconf: fatal: open /etc/postfix/main.cf for reading: No such file or directory

I've then messed around but well... not the way. I've reinstalled the server and started over. Unlucky me with the same result (see complete console output attached, i've changed to domain and hostname in the text file)

I've stopped the iRedMail setup, deleted the config file, copied the main.cf:

cp /usr/share/postfix/main.cf.debian /etc/postfix/main.cf

and started iRedMail setup again, this time with no issues.

The tools seem to run. Roundcube hat a quick popup because of some sieve mail filter connection (too quickly gone to read)

I've also added the workaround mentioned in the comments at: http://code.google.com/p/iredmail/wiki/ … _on_Ubuntu
(to remove a race condition in fail2ban)

Now is the result of the setup probably ok or is this also considered as messing around?

Thanks a lot!
kind regards


Post's attachments

iredmail.console.txt 84.9 kb, 2 downloads since 2011-05-14 

You don't have the permssions to download the attachments of this post.