Topic: Roundcube webmail not starting up

I installed iRedmail v0.1.4 on Ubuntu 10.10. Everything went on smoothly. I was able to configure accounts receive and send mails using a mail client and also the roundcube webmail.

I had to restart my system due to a different issue. After this when i start iRedmail using the script, the roundcube webmail fails to come up. I am able to sent and receive messages from my mail clients. The /var/log/mail/log says

"exchangeim roundcube: PHP Fatal error:  Cannot redeclare class password in /usr/share/apache2/roundcubemail-0.5.2/plugins/password/password.php on line 265"

Does anyone have any idea?

Thanks in Advance


Re: Roundcube webmail not starting up

Roundcube plugin "password" requires addition package "php-net-ldap2". Please make sure you have it installed, then restart apache.

# apt-get update
# apt-get install php-net-ldap2


Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee


Re: Roundcube webmail not starting up

I did that. Still getting the same error.

I am being asked to accept the certificate in my browser while accessing the webmail. After that it just goes to a blank page. Also FYI.. I am running this entire setup on a VM.


Re: Roundcube webmail not starting up

Solved it. Courtesy http://www.iredmail.org/forum/topic1853 … hp-53.html

Edit the file main.inc.php (in /usr/share/apache2/roundcubemail-0.5.2/config)

Find these lines:

// List of active plugins (in plugins/ directory)
$rcmail_config['plugins'] = array("password","managesieve",);

Make sure the array only has one instance of each plugin.