1

Topic: [OpenBSD] Bug report for installer

Hi Zhang,

I am giving you a heads up regarding a recent OpenBSD development, part way through OpenBSD release 6.5 a new feature was implemented for -stable binary package updates.

For example, on OpenBSD 6.5 right now the PHP versions available are:

doas pkg_info -Q php 

php-7.1.32
php-7.2.22
php-7.3.9

But in the functions/packages.sh script in the installer it targets specific versions that are now out of date

# OpenBSD-6.5
OB_PKG_PHP_VER='-7.3.4'
OB_PKG_OPENLDAP_SERVER_VER='-2.4.47p0'
OB_PKG_OPENLDAP_CLIENT_VER='-2.4.47p0'

Instead of targeting specific versions you may want to just target major.minor and use fuzzy package installs like so

$ doas pkg_add -z php-7.3* 
quirks-3.124 signed on 2019-09-16T08:18:29Z
https://openbsd.cs.toronto.edu/pub/OpenBSD//6.5/packages-stable/amd64/php-7.1.32.tgz: Requesting https://openbsd.cs.toronto.edu/pub/OpenBSD//6.5/packages-stable/amd64/php-7.1.32.tgz
php-7.3.9:oniguruma-6.9.1: ok
php-7.3.9:femail-1.0p1: ok
php-7.3.9:femail-chroot-1.0p3: ok
php-7.3.9: ok
The following new rcscripts were installed: /etc/rc.d/php73_fpm
See rcctl(8) for details.
New and changed readme(s):
    /usr/local/share/doc/pkg-readmes/femail-chroot
    /usr/local/share/doc/pkg-readmes/php-7.3 

2

Re: [OpenBSD] Bug report for installer

Dear @daulton,

Thanks for the remind.
Yes i'm aware of this and the latest iRedMail-1.0-beta1 uses 7.3 branch (%7.3) directly, no more hard-coded 7.3.X.
https://bitbucket.org/zhb/iredmail/src/ … h#lines-34

        OB_PKG_PHP_VER='%7.3'

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee