1

Topic: iredadmin wont start

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 0.9.9
- Deployed with iRedMail Easy or the downloadable installer? downloadable installer
- Linux/BSD distribution name and version: OpenBSD 6.6
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): pgsql
- Web server (Apache or Nginx): nginx
- Manage mail accounts with iRedAdmin-Pro? No
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

As you can see below iRedadmin has a dependency on an unavailable library version for libiconv on OpenBSD 6.6 and will not start.

mx# uname -a         
OpenBSD mx.tetmail.ca 6.6 GENERIC#0 amd64
mx# rcctl check iredadmin
iredadmin(failed)
mx# rcctl -d start iredadmin
doing _rc_parse_conf
doing _rc_quirks
iredadmin_flags empty, using default ><
doing _rc_parse_conf /var/run/rc.d/iredadmin
doing _rc_quirks
doing rc_check
iredadmin
doing rc_pre
doing rc_start
doing _rc_wait start
doing rc_check
ld.so: uwsgi: can't load library 'libiconv.so.6.0'
Killed
doing _rc_rm_runfile
(failed)
mx# pkg_info -Q libiconv
libiconv-1.16p0 (installed)

2

Re: iredadmin wont start

iRedMail-0.9.9 doesn't support OpenBSD 6.6, please try iRedMail-1.0-beta2 (or check out the latest development edition) instead.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee