1

Topic: UWSGI confusion

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.0
- Deployed with iRedMail Easy or the downloadable installer?: neither, manual
- Linux/BSD distribution name and version: FreeBSD 11.3
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL 8.0.19
- Web server (Apache or Nginx): Nginx 1.16
- Manage mail accounts with iRedAdmin-Pro? Yes, IredAdmin-Pro 4.2
- UWSGI-2.0.18

I am not sure if the UWSGI service is required to run either the iredadmin process or mlmmjadmin.
In order to test whether there is a dependency, I deleted the UWSGI package. Both iredadmin and mlmmjadmin processes remain operational. However, when I try to stop the mlmmjadmin process the following error is returned:

/usr/local/etc/rc.d/mlmmjadmin stop
Stopping mlmmjadmin.
eval: uwsgi: not found
        [ FAILED ]

So apparently there is a requirement, but UWSGI is not registered as a dependency?

I reinstalled UWSGI and was able to stop and restart mlmmjadmin.

iRedAdmin-Pro is running properly, but the UWSGI service is not active. Is there a library dependency?

2

Re: UWSGI confusion

we use the uwsgi command, not the uwsgi service. smile

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee