1

Topic: to enable UTF-8 on FreeBSD on a server running iRedMail

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.1 OPENLDAP edition.
- Deployed with iRedMail Easy or the downloadable installer? downloadable installer
- Linux/BSD distribution name and version: Freebsd 12.1
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? No
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====
Hi there,
I'm needing to use UTF-8 on a FreeBSD Server that is primarily configured for iRedMail.

By default, FreeBSD is not configured to use UTF-8.
Can I ask if anyone is using UTF-8 on FreeBSD with iRedMail?

Here's what I get if I run: $ locale
LANG=
LC_CTYPE="C"
LC_COLLATE="C"
LC_TIME="C"
LC_NUMERIC="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_ALL=

I'm intending to enable UTF-8 a system-wide, by following this tutorial
https://www.b1c1l1.com/blog/2011/05/09/ … n-freebsd/

I did a quick search and found some issues with RoundcubeMail and utf-8 encodings and I'm wondering if it is safe to go on with it. Any advice on how best to go about it.

Thanks!

2

Re: to enable UTF-8 on FreeBSD on a server running iRedMail

You need Postfix-3.0 or later release for smtp utf8 support:
http://www.postfix.org/postconf.5.html#smtputf8_enable

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee