1

Topic: iRedMail new install 1.3.1: "python setup.py egg_info" failed

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.3.1
- Deployed with iRedMail Easy or the downloadable installer? downloadable installer
- Linux/BSD distribution name and version: Debian 10
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MariaDB
- Web server (Apache or Nginx):Nginx
- Manage mail accounts with iRedAdmin-Pro? yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Hello dear Support Team!

On a new iRedMail 1.3.1 install on recommened Debian 10, I get following error during installation:

[ INFO ] Installing required Python-2 modules with pip2: web.py>=0.51 more-itertools==5.0.0
Collecting web.py>=0.51
  Downloading https://files.pythonhosted.org/packages/f9/5f/2d0eb552180157e546307f8884009db614f50d9fe01eab70d080944bbe2b/web.py-0.60.tar.gz (105kB)
  Installing build dependencies: started
  Installing build dependencies: finished with status 'done'
    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-WTdqcY/web.py/setup.py", line 7, in <module>
        from web import __version__
      File "web/__init__.py", line 4, in <module>
        from . import (  # noqa: F401
      File "web/db.py", line 771
        print("ERR:", str(sql_query), file=debug)
                                          ^
    SyntaxError: invalid syntax
    
    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-install-WTdqcY/web.py/
[ INFO ] Installing required Python-3 modules with pip3: web.py>=0.51 web.py>=0.51

I wonder what could possibly cause that issue.

Debian 10 was freshly installed with all updates prior installing iRedMail 1.3.1

Can I continue use that server to migrate data from an older iRedMail installation or shall I start from scratch?

Best regards,
Bernhard

2

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

When installing iRedAdmin-Pro, I get following error:

* Creating symbol link /opt/www/iredadmin to /opt/www/iRedAdmin-Pro-SQL-4.4
Traceback (most recent call last):
  File "delete_sessions.py", line 9, in <module>
    import web
ImportError: No module named web
* Enable mlmmj integration.

"Internal server error" is shown when accessing /iredadmin

This is very much related to the installation error above

3

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

I found https://forum.iredmail.org/topic17147-i … ssing.html but my installer is from Jul 26

So I should have the fixed version now but am still getting the error.

Strange:

In another browser-tab I had the Download-Page open from this morning.
"Stable" links there to https://github.com/iredmail/iRedMail/ar … 3.1.tar.gz

whereas a new tab with the download link now goes to

https://github.com/iredmail/iRedMail/re … 3.1.tar.gz

Something changed.

I will install all new from scratch with the "new" file

4

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

Fixed, with the "new" "new" 1.3.1 package it works.

Only question left: Why did I download today the old version?

5

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

For Python 2, please run "pip2 install web.py==0.51". There's a problem with 0.60 which doesn't indicate it doesn't support Python 2.
For Python 3, please run "pip3 install web.py" directly, it will install the latest 0.61.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

6

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

Thank you!

What do you recommend for Debian 10?
Shall I install the version 0.61 or stay with the one the iRedMail installer used?

7

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

I’m afraid that you have to install both right now:

- iRedAPD and mlmmjadmin require Python 3 and web.py==0.61.
- iRedAdmin(-Pro) still requires Python 2 and web.py==0.51.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

8

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

Btw, we’re moving iRedAdmin(-Pro) to Python 3, it may take few more months.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

9

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

ZhangHuangbin wrote:

- iRedAPD and mlmmjadmin require Python 3 and web.py==0.61.
- iRedAdmin(-Pro) still requires Python 2 and web.py==0.51.

Looks like iRedMail-1.3.1 installed only web-py 0.51 for both python versions:

root@debmail1:~# pip2 install web.py==0.51
Requirement already satisfied: web.py==0.51 in /usr/local/lib/python2.7/dist-packages (0.51)
Requirement already satisfied: cheroot in /usr/local/lib/python2.7/dist-packages (from web.py==0.51) (8.4.0)
Requirement already satisfied: backports.functools-lru-cache; python_version < "3.3" in /usr/local/lib/python2.7/dist-packages (from cheroot->web.py==0.51) (1.6.1)
Requirement already satisfied: selectors2; python_version < "3.4" in /usr/local/lib/python2.7/dist-packages (from cheroot->web.py==0.51) (2.0.2)
Requirement already satisfied: more-itertools>=2.6 in /usr/local/lib/python2.7/dist-packages (from cheroot->web.py==0.51) (5.0.0)
Requirement already satisfied: six>=1.11.0 in /usr/lib/python2.7/dist-packages (from cheroot->web.py==0.51) (1.12.0)
Requirement already satisfied: jaraco.functools in /usr/local/lib/python2.7/dist-packages (from cheroot->web.py==0.51) (2.0)
root@debmail1:~# pip3 install web.py
Requirement already satisfied: web.py in /usr/local/lib/python3.7/dist-packages (0.51)
Requirement already satisfied: cheroot in /usr/local/lib/python3.7/dist-packages (from web.py) (8.4.0)
Requirement already satisfied: jaraco.functools in /usr/local/lib/python3.7/dist-packages (from cheroot->web.py) (3.0.1)
Requirement already satisfied: six>=1.11.0 in /usr/lib/python3/dist-packages (from cheroot->web.py) (1.12.0)
Requirement already satisfied: more-itertools>=2.6 in /usr/local/lib/python3.7/dist-packages (from cheroot->web.py) (8.4.0)

I fixed the issue by installing manually:

root@debmail1:~# pip3 install web.py==0.61
Collecting web.py==0.61
  Downloading https://files.pythonhosted.org/packages/ed/f5/2dfe7585f13e3847d6e1d895bd08f4c7fba91e46e0d2bf9e433969c6c78d/web.py-0.61-py3-none-any.whl (78kB)
    100% |████████████████████████████████| 81kB 3.3MB/s 
Requirement already satisfied: cheroot in /usr/local/lib/python3.7/dist-packages (from web.py==0.61) (8.4.0)
Requirement already satisfied: more-itertools>=2.6 in /usr/local/lib/python3.7/dist-packages (from cheroot->web.py==0.61) (8.4.0)
Requirement already satisfied: jaraco.functools in /usr/local/lib/python3.7/dist-packages (from cheroot->web.py==0.61) (3.0.1)
Requirement already satisfied: six>=1.11.0 in /usr/lib/python3/dist-packages (from cheroot->web.py==0.61) (1.12.0)
Installing collected packages: web.py
  Found existing installation: web.py 0.60
    Uninstalling web.py-0.60:
      Successfully uninstalled web.py-0.60
Successfully installed web.py-0.61

Due to a typo just seconds before I installed 0.60, don't get confused.

if 0.61 is required by iRedAPD and mlmmjadmin, maybe you'd like to doublecheck if iRedMail-1.3.1 is really installing the required versions.

10

Re: iRedMail new install 1.3.1: "python setup.py egg_info" failed

broth wrote:

Looks like iRedMail-1.3.1 installed only web-py 0.51 for both python versions:

You're right.
Just re-packaged iRedMail-1.3.1 with correct version for both Python 2 (==0.51) and 3 (>=0.61).

Thank you Broth. smile

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee