1 (edited by pawtracks 2020-07-31 08:03:22)

Topic: [RESOLVED] Whitelist and blacklist entires not being applied

- iRedMail version (check /etc/iredmail-release): 1.3.1
- Deployed with iRedMail Easy or the downloadable installer? Downloadable
- Linux/BSD distribution name and version: CentOS Linux release 7.8.2003 (Core)
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL/MariaDB
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? No
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.

I noticed browsing my .bash_history that I entered the (3) working whitelist items with the python vice python3 command
python wblist_admin.py --add --whitelist @domain1.com user@domain3.com @domain2.com
-These are the (3) working entries displayed

[root@mailio tools]# /usr/bin/python3 -V
Python 3.6.8
[root@mailio tools]# /usr/bin/python -V
Python 2.7.5

Following the commands from this guide

iRedAPD 4.4
# Enabled plugins.
plugins = ["reject_null_sender", "wblist_rdns", "reject_sender_login_mismatch", "greylisting", "throttle", "amavisd_wblist", "sql_alias_access_policy"]

This is a pretty new server build, less than 3 months old, deployed as 1.2.1 version
I was able to add a few white listed items at initial setup, but now it appears something is broken.

I start by
cd /opt/iredapd/tools/

python3 wblist_admin.py --list --whitelist
It shows me (2) domains and (1) email account, as expected from setup 3 months ago

If I try and add a new whitelist entry
[root@mailio tools]# python3 wblist_admin.py --add --whitelist sender@example.com
* Establishing SQL connection.
* Add inbound whitelist for account: @.
* Add senders: sender@example.com

It is not clear to me if I need to restart any services, but I have restarted: iredapd, postfix and amavisd services

Then, python3 wblist_admin.py --list --whitelist
Still only shows me the original (3) entries I made ~3 months ago (not my new entry I tried to add)

Similar issues for entering either a blacklist domain entry or entries for a particular user account
[root@mailio tools]# python3 wblist_admin.py --account sender@example.com --add --blacklist pawtracks@hotmail.com
* Establishing SQL connection.
* Add inbound blacklist for account: sender@example.com
* Add senders: pawtracks@hotmail.com

If I browse the database directly, I can see that the items are being entered in the appropriate database and table.
amavisd, table mailaddr
I see my (3) working whitelisted entries
as well as
The 5 entries I have tried to either whitelist or blacklist today

Hopefully someone has an idea of what I am missing or has had similar issues.


Re: [RESOLVED] Whitelist and blacklist entires not being applied

I fixed the issues, doing a fresh install of iRedAPD 4.4, all whitelist and blacklist features, tested and working.

Decided to try and follow similar issues in this reply