1 (edited by RadApl 2021-06-07 01:06:55)

Topic: ldap(slapd) not starting after reboot

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.4
- Deployed with iRedMail Easy or the downloadable installer? installer
- Linux/BSD distribution name and version: Ubunu Server 20.04
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP
- Web server (Apache or Nginx):Ngnix
- Manage mail accounts with iRedAdmin-Pro? No
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Good day,
ldap server not starting after reboot, can't find a reason. Manually ok:

root@mail:/home/sysadmin# systemctl status slapd
● slapd.service - LSB: OpenLDAP standalone server (Lightweight Directory Access Protocol)
     Loaded: loaded (/etc/init.d/slapd; static; vendor preset: enabled)
    Drop-In: /usr/lib/systemd/system/slapd.service.d
             └─slapd-remain-after-exit.conf
     Active: inactive (dead)
       Docs: man:systemd-sysv-generator(8)

root@mail:/home/sysadmin# systemctl start slapd
root@mail:/home/sysadmin# systemctl status slapd
● slapd.service - LSB: OpenLDAP standalone server (Lightweight Directory Access Protocol)
     Loaded: loaded (/etc/init.d/slapd; static; vendor preset: enabled)
    Drop-In: /usr/lib/systemd/system/slapd.service.d
             └─slapd-remain-after-exit.conf
     Active: active (running) since Sun 2021-06-06 18:48:43 EET; 29s ago
       Docs: man:systemd-sysv-generator(8)
    Process: 3503 ExecStart=/etc/init.d/slapd start (code=exited, status=0/SUCCESS)
      Tasks: 3 (limit: 4554)
     Memory: 6.5M
     CGroup: /system.slice/slapd.service
             └─3530 /usr/sbin/slapd -h ldap:/// ldapi:/// ldaps:/// -g openldap -u openldap -f /etc/ldap/slapd.conf

Jun 06 18:48:43 mail.***.com systemd[1]: Starting LSB: OpenLDAP standalone server (Lightweight Directory Access Pro>
Jun 06 18:48:43 mail.***.com slapd[3503]:  * Starting OpenLDAP slapd
Jun 06 18:48:43 mail.***.com slapd[3529]: @(#) $OpenLDAP: slapd  (Ubuntu) (Apr  8 2021 04:22:01) $
                                                      Debian OpenLDAP Maintainers <pkg-openldap-devel@lists.alioth.debi>
Jun 06 18:48:43 mail.***.com slapd[3503]:    ...done.
Jun 06 18:48:43 mail.***.com systemd[1]: Started LSB: OpenLDAP standalone server (Lightweight Directory Access Prot>
lines 1-18/18 (END)

Nothing strange in /var/log/syslog and /var/log/mail.log. /var/log/openldap/openldap.log is empty.

Thank you

2

Re: ldap(slapd) not starting after reboot

Try to run openldap manually with command below:

/usr/sbin/slapd -h ldap:/// ldapi:/// ldaps:/// -g openldap -u openldap -f /etc/ldap/slapd.conf -d 256

Show us last 30 lines on console for troubleshooting.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee