1

Topic: New Mailing List - not setting 'Reply-To' for postings

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 2021062401
- Deployed with iRedMail Easy or the downloadable installer? download installer originally, migrated to Easy
- Linux/BSD distribution name and version: Debian 10
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? Yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====


I set up a new mailing list on our server last week - but when emails are sent, the 'Reply-To' isn't being set for the Mailing list,  so people who click 'Reply' are going back to the original sender and not the list itself.

The other (older) mailing lists I already had set up on the mail server do honour this behaviour.

I've gone through all the setup screen - comparing an old versus the new mailing list and they appear to be the same.

Any ideas ?

Thanks
Kent.

2

Re: New Mailing List - not setting 'Reply-To' for postings

kent@kamar.nz wrote:

I set up a new mailing list

Is it a subscribeable mailing list?

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

3

Re: New Mailing List - not setting 'Reply-To' for postings

ZhangHuangbin wrote:
kent@kamar.nz wrote:

I set up a new mailing list

Is it a subscribeable mailing list?


Both lists have the following option enabled:
> Subscription control:  Disable subscription and unsubscription via email

Does this make a difference ?



Both are private mailing lists - I add/remove the recipients manually.

Cheers
Kent.

4

Re: New Mailing List - not setting 'Reply-To' for postings

Check this ChangeLog line: https://github.com/iredmail/mlmmjadmin/ … ngeLog#L67

- Fixed: Don't always set header `Reply-To:` (leave it to MUA).

We used to always set "Reply-To:", but it was changed in mlmmjadmin-1.7.

Question: does your MUA set this Reply-To:? Which address did it use?

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

5

Re: New Mailing List - not setting 'Reply-To' for postings

ZhangHuangbin wrote:
kent@kamar.nz wrote:

I set up a new mailing list

Is it a subscribeable mailing list?


These are my settings.  Same on both mailing lists as far as I can tell.

Post's attachments

Screen Shot 2021-08-09 at 10.04.31 PM.png 209.57 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

6 (edited by kent@kamar.nz 2021-08-10 05:01:24)

Re: New Mailing List - not setting 'Reply-To' for postings

ZhangHuangbin wrote:

Check this ChangeLog line: https://github.com/iredmail/mlmmjadmin/ … ngeLog#L67

- Fixed: Don't always set header `Reply-To:` (leave it to MUA).

We used to always set "Reply-To:", but it was changed in mlmmjadmin-1.7.

Question: does your MUA set this Reply-To:? Which address did it use?


Hi Zhang,

The two mailing lists I'm comparing against are both hosted on the same server, and I'm sending to myself (also a user on the same mail server).  Therefore the only mail server in my testing process is the iRedAdmin / iRedMail server.

What I want is the new mailing list to by default reply to the mailing list.   Looking at the two, the only difference I've identified is the original mailing list has a 'Reply-To' and 'X-Mailing-List' headers and the new mailing list doesn't have either of these.

Reply-To: listname@somedomain.nz
X-Mailing-List: listname@somedomain.nz


The problem is,  some recipients don't realise and they are only replying to the original sender of the message they are replying to and not the list,  so the discussion is broken.

Thanks
Kent.

7

Re: New Mailing List - not setting 'Reply-To' for postings

Hi Zhang,

Any ideas on how I can get the new mailing list to always reply to the mailing list (by default) ?

Either via the addition of the 'Reply-To' header - or some other way ?

There must be a setting to do this somewhere - as my older mailing lists do this.

Thanks
Kent.

8

Re: New Mailing List - not setting 'Reply-To' for postings

Try this:

To ALWAYS add "Reply-To: <email>" for ALL mailing lists, append below line in /opt/mlmmjadmin/settings.py, then restart "mlmmjadmin" service:

MLMMJ_DEFAULT_CUSTOM_HEADERS.update({'Reply-To': '%(mail)s'})

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee