1 (edited by essecitech 2021-10-03 23:12:43)

Topic: Sogo update failed

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.4.0
- Deployed with iRedMail Easy or the downloadable installer? Easy
- Linux/BSD distribution name and version: Ubuntu 18.04 LTS
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySql
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? NO
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

I haven’t been able to update Sogo for a few days
During apt-get update I get:
Download of:6 https://packages.inverse.ca/SOGo/nightly/5/ubuntu bionic InRelease [2.642 B]
but when I make apt-get upgrade I have some errors:
Error: https://packages.inverse.ca/SOGo/nightly/5/ubuntu bionic/bionic amd64 sogo-activesync amd64 5.2.0.20211001-1
  404  Not Found [IP: 96.16.248.162 443]

and

Error: https://packages.inverse.ca/SOGo/nightly/5/ubuntu bionic/bionic amd64 sogo amd64 5.2.0.20211001-1
  404  Not Found [IP: 96.16.248.162 443]

Please, help me.
Thank you



UPDATE:
Examining the file https://packages.inverse.ca/SOGo/nightl … 4/Packages I see:
Package: sogo-activesync
Source: sogo
Version: 5.2.0.20211001-1
Architecture: amd64
Maintainer: Inverse Support <support@inverse.ca>
Installed-Size: 1882
Depends: sogo (= 5.2.0.20211001-1), libwbxml2-0 (>= 0.11.2), gnustep-base-runtime (>= 1.25.1), libc6 (>= 2.14), libgcc1 (>= 1:3.0), libgnustep-base1.25 (>= 1.25.1), libobjc4 (>= 4.2.1), libsbjson2.3 (>= 4.9.r1664.20211001), libsope-appserver4.9 (>= 4.9.r1664.20211001), libsope-core4.9 (>= 4.9.r1664.20211001), libsope-gdl1-4.9 (>= 4.9.r1664.20211001), libsope-ldap4.9 (>= 4.9.r1664.20211001), libsope-mime4.9 (>= 4.9.r1664.20211001), libsope-xml4.9 (>= 4.9.r1664.20211001), libssl1.1 (>= 1.1.0)
Priority: extra
Section: web
Filename: pool/bionic/s/sogo/sogo-activesync_5.2.0.20211001-1_amd64.deb
Size: 1440648

but in https://packages.inverse.ca/SOGo/nightl … ic/s/sogo/ there isn't that file.
Only sogo-activesync_5.2.0.20211002-1_amd64.deb and sogo-activesync_5.2.0.20211003-1_amd64.deb

Any suggestion?

2

Re: Sogo update failed

Seems something on SOGo apt repository. Please wait and try again later.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

3

Re: Sogo update failed

iredmail release 1.4.2 MARIADB edition
downloadable installer
Rocky Linux 8.4
MariaDB
Nginx
No

I'm throwing repository errors too. Is this a wait and see situation?

Inverse SOGo Repository                                                                                                                                                       215 kB/s |  69 kB     00:00
Error:
Problem 1: package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - cannot install the best update candidate for package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64
  - cannot install the best update candidate for package gnustep-base-libs-1.24.9-1.el8.x86_64
Problem 2: package sogo-5.2.0.20211010-1.el8.x86_64 requires sope49-sbjson, but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - package gnustep-base-1.28.0-3.el8.x86_64 requires libgnustep-base.so.1.28()(64bit), but none of the providers can be installed
  - package gnustep-base-1.28.0-3.el8.x86_64 requires gnustep-base-libs(x86-64) = 1.28.0-3.el8, but none of the providers can be installed
  - cannot install the best update candidate for package sogo-5.2.0.20211006-1.el8.x86_64
  - cannot install the best update candidate for package gnustep-base-1.24.9-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)






ZhangHuangbin wrote:

Seems something on SOGo apt repository. Please wait and try again later.

4

Re: Sogo update failed

montanelli wrote:

I'm throwing repository errors too. Is this a wait and see situation?

Could you please try again?
I see SOGo yum repo has the required packages:
https://packages.inverse.ca/SOGo/nightl … 6_64/RPMS/

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

5

Re: Sogo update failed

redmail release 1.4.2 MARIADB edition
downloadable installer
Rocky Linux 8.4
MariaDB
Nginx
No

I'm now showing a conflict between epel and sogo repos.
If I "--allowerasing" it will remove sogo
If I "--skip-broken" it won't proceed
If I "--nobest" it won't install either gnustep packages

No repo on my list has any libgnustep* packages.

I'm gonna wait some more.

[root@mail yum.repos.d]# dnf update
Last metadata expiration check: 0:14:39 ago on Tue 12 Oct 2021 04:05:13 PM EDT.
Error:
Problem 1: package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - cannot install the best update candidate for package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64
  - cannot install the best update candidate for package gnustep-base-libs-1.24.9-1.el8.x86_64
Problem 2: package sogo-5.2.0.20211012-1.el8.x86_64 requires sope49-sbjson, but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - package gnustep-base-1.28.0-3.el8.x86_64 requires libgnustep-base.so.1.28()(64bit), but none of the providers can be installed
  - package gnustep-base-1.28.0-3.el8.x86_64 requires gnustep-base-libs(x86-64) = 1.28.0-3.el8, but none of the providers can be installed
  - cannot install the best update candidate for package sogo-5.2.0.20210927-1.el8.x86_64
  - cannot install the best update candidate for package gnustep-base-1.24.9-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)



ZhangHuangbin wrote:
montanelli wrote:

I'm throwing repository errors too. Is this a wait and see situation?

Could you please try again?
I see SOGo yum repo has the required packages:
https://packages.inverse.ca/SOGo/nightl … 6_64/RPMS/

6

Re: Sogo update failed

In absence of guidance and comment and looking over the errors I have decided to exclude gnustep-base from epel repo update. I am not recommending this for anyone else, YMMV, comments invited.

My epel repo now looks like this and the conflicts listed in the update are resolved.

[epel]
name=Extra Packages for Enterprise Linux $releasever - $basearch
# It is much more secure to use the metalink, but if you wish to use a local mirror
# place its address here.
#baseurl=https://download.example/pub/epel/$releasever/Everything/$basearch
metalink=https://mirrors.fedoraproject.org/metalink?repo=epel-$releasever&arch=$basearch&infra=$infra&content=$contentdir
enabled=1
gpgcheck=1
countme=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-8
exclude=gnustep-base*




montanelli wrote:

redmail release 1.4.2 MARIADB edition
downloadable installer
Rocky Linux 8.4
MariaDB
Nginx
No

I'm now showing a conflict between epel and sogo repos.
If I "--allowerasing" it will remove sogo
If I "--skip-broken" it won't proceed
If I "--nobest" it won't install either gnustep packages

No repo on my list has any libgnustep* packages.

I'm gonna wait some more.

[root@mail yum.repos.d]# dnf update
Last metadata expiration check: 0:14:39 ago on Tue 12 Oct 2021 04:05:13 PM EDT.
Error:
Problem 1: package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - cannot install the best update candidate for package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64
  - cannot install the best update candidate for package gnustep-base-libs-1.24.9-1.el8.x86_64
Problem 2: package sogo-5.2.0.20211012-1.el8.x86_64 requires sope49-sbjson, but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - package gnustep-base-1.28.0-3.el8.x86_64 requires libgnustep-base.so.1.28()(64bit), but none of the providers can be installed
  - package gnustep-base-1.28.0-3.el8.x86_64 requires gnustep-base-libs(x86-64) = 1.28.0-3.el8, but none of the providers can be installed
  - cannot install the best update candidate for package sogo-5.2.0.20210927-1.el8.x86_64
  - cannot install the best update candidate for package gnustep-base-1.24.9-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)



ZhangHuangbin wrote:
montanelli wrote:

I'm throwing repository errors too. Is this a wait and see situation?

Could you please try again?
I see SOGo yum repo has the required packages:
https://packages.inverse.ca/SOGo/nightl … 6_64/RPMS/

7

Re: Sogo update failed

I haven't updated yet because something doesn' t seem right, if I exclude gnustep-* from epel, then it still want's to grab libwbxml from epel and it doesn't include the gnustep-* packages from Sogo.



montanelli wrote:

In absence of guidance and comment and looking over the errors I have decided to exclude gnustep-base from epel repo update. I am not recommending this for anyone else, YMMV, comments invited.

My epel repo now looks like this and the conflicts listed in the update are resolved.

[epel]
name=Extra Packages for Enterprise Linux $releasever - $basearch
# It is much more secure to use the metalink, but if you wish to use a local mirror
# place its address here.
#baseurl=https://download.example/pub/epel/$releasever/Everything/$basearch
metalink=https://mirrors.fedoraproject.org/metalink?repo=epel-$releasever&arch=$basearch&infra=$infra&content=$contentdir
enabled=1
gpgcheck=1
countme=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-8
exclude=gnustep-base*




montanelli wrote:

redmail release 1.4.2 MARIADB edition
downloadable installer
Rocky Linux 8.4
MariaDB
Nginx
No

I'm now showing a conflict between epel and sogo repos.
If I "--allowerasing" it will remove sogo
If I "--skip-broken" it won't proceed
If I "--nobest" it won't install either gnustep packages

No repo on my list has any libgnustep* packages.

I'm gonna wait some more.

[root@mail yum.repos.d]# dnf update
Last metadata expiration check: 0:14:39 ago on Tue 12 Oct 2021 04:05:13 PM EDT.
Error:
Problem 1: package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - cannot install the best update candidate for package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64
  - cannot install the best update candidate for package gnustep-base-libs-1.24.9-1.el8.x86_64
Problem 2: package sogo-5.2.0.20211012-1.el8.x86_64 requires sope49-sbjson, but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - package gnustep-base-1.28.0-3.el8.x86_64 requires libgnustep-base.so.1.28()(64bit), but none of the providers can be installed
  - package gnustep-base-1.28.0-3.el8.x86_64 requires gnustep-base-libs(x86-64) = 1.28.0-3.el8, but none of the providers can be installed
  - cannot install the best update candidate for package sogo-5.2.0.20210927-1.el8.x86_64
  - cannot install the best update candidate for package gnustep-base-1.24.9-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)



ZhangHuangbin wrote:

Could you please try again?
I see SOGo yum repo has the required packages:
https://packages.inverse.ca/SOGo/nightl … 6_64/RPMS/

8 (edited by montanelli 2021-10-13 23:55:16)

Re: Sogo update failed

They aren't being included from Sogo because the already installed gnustep-* files are the latest from Sogo. I don't like when repos don't play nice with each other.

I'm waiting for comment a while longer before I update Sogo.

montanelli wrote:

I haven't updated yet because something doesn' t seem right, if I exclude gnustep-* from epel, then it still want's to grab libwbxml from epel and it doesn't include the gnustep-* packages from Sogo.



montanelli wrote:

In absence of guidance and comment and looking over the errors I have decided to exclude gnustep-base from epel repo update. I am not recommending this for anyone else, YMMV, comments invited.

My epel repo now looks like this and the conflicts listed in the update are resolved.

[epel]
name=Extra Packages for Enterprise Linux $releasever - $basearch
# It is much more secure to use the metalink, but if you wish to use a local mirror
# place its address here.
#baseurl=https://download.example/pub/epel/$releasever/Everything/$basearch
metalink=https://mirrors.fedoraproject.org/metalink?repo=epel-$releasever&arch=$basearch&infra=$infra&content=$contentdir
enabled=1
gpgcheck=1
countme=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL-8
exclude=gnustep-base*




montanelli wrote:

redmail release 1.4.2 MARIADB edition
downloadable installer
Rocky Linux 8.4
MariaDB
Nginx
No

I'm now showing a conflict between epel and sogo repos.
If I "--allowerasing" it will remove sogo
If I "--skip-broken" it won't proceed
If I "--nobest" it won't install either gnustep packages

No repo on my list has any libgnustep* packages.

I'm gonna wait some more.

[root@mail yum.repos.d]# dnf update
Last metadata expiration check: 0:14:39 ago on Tue 12 Oct 2021 04:05:13 PM EDT.
Error:
Problem 1: package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - cannot install the best update candidate for package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64
  - cannot install the best update candidate for package gnustep-base-libs-1.24.9-1.el8.x86_64
Problem 2: package sogo-5.2.0.20211012-1.el8.x86_64 requires sope49-sbjson, but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20210923_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - package sope49-sbjson-2.3.1-20211001_1664.el8.1.1.x86_64 requires libgnustep-base.so.1.24()(64bit), but none of the providers can be installed
  - cannot install both gnustep-base-libs-1.28.0-3.el8.x86_64 and gnustep-base-libs-1.24.9-1.el8.x86_64
  - cannot install both gnustep-base-libs-1.24.9-1.el8.x86_64 and gnustep-base-libs-1.28.0-3.el8.x86_64
  - package gnustep-base-1.28.0-3.el8.x86_64 requires libgnustep-base.so.1.28()(64bit), but none of the providers can be installed
  - package gnustep-base-1.28.0-3.el8.x86_64 requires gnustep-base-libs(x86-64) = 1.28.0-3.el8, but none of the providers can be installed
  - cannot install the best update candidate for package sogo-5.2.0.20210927-1.el8.x86_64
  - cannot install the best update candidate for package gnustep-base-1.24.9-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)