1 (edited by haxpor 2022-04-06 21:06:56)

Topic: iredmail 0.9.2 didn't install anything from existing config file

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 0.9.2
- Deployed with iRedMail Easy or the downloadable installer? downloadable installer
- Linux/BSD distribution name and version: Ubuntu 20.04 LTS
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? no
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue. : See below
====

I migrate iredmail 0.9.2 from Ubuntu 14.04 to 20.04 on a new server.
I have existing backed up data, and existing config used for new installation.

I execute with the following and result it shows


$ AUTO_USE_EXISTING_CONFIG_FILE=y bash iRedMail.sh
[ INFO ] Checking configuration file: /root/Data/Projects/iRedMail-0.9.2/config ... [FOUND]
< Question > Use it for mail server setting? [y|N]y
[ INFO ] Use config file: /root/Data/Projects/iRedMail-0.9.2/config for mail server setting.
[ INFO ] Import installation process status from file: /root/Data/Projects/iRedMail-0.9.2/runtime/install.status.
< SKIP > Function: install_all.

********************************************************************
* Start iRedMail Configurations
********************************************************************
[ INFO ] Create self-signed SSL certification files (2048 bits).
[ INFO ] Generate a strong, unique Diffie Hellman Group with openssl, please wait.
< SKIP > Function: add_required_users.
< SKIP > Function: web_server_config.
[ INFO ] Configure MySQL database server.
< SKIP > Function: mysql_initialize.
< SKIP > Function: mysql_import_vmail_users.
< SKIP > Function: mysql_cron_backup.
< SKIP > Function: postfix_config_basic.
< SKIP > Function: postfix_config_virtual_host.
< SKIP > Function: postfix_config_sasl.
< SKIP > Function: postfix_config_tls.
< SKIP > Function: policy_server_config.
< SKIP > Function: enable_dovecot.
< SKIP > Function: clamav_config.
< SKIP > Function: amavisd_config_debian.
< SKIP > Function: amavisd_config_general.
< SKIP > Function: amavisd_import_sql.
< SKIP > Function: sa_config.
< SKIP > Function: iredapd_config.
< SKIP > Function: iredadmin_config.
< SKIP > Function: rcm_install.
< SKIP > Function: rcm_import_sql.
< SKIP > Function: rcm_config.
< SKIP > Function: rcm_plugin_managesieve.
< SKIP > Function: rcm_plugin_password.
< SKIP > Function: cleanup.

It didn't install anything. Any help would be appreciated.

----

Spider Email Archiver: On-Premises, lightweight email archiving software developed by iRedMail team.

2

Re: iredmail 0.9.2 didn't install anything from existing config file

[ INFO ] Import installation process status from file: /root/Data/Projects/iRedMail-0.9.2/runtime/install.status


It skips everything because it asumes that all steps were already finnished

Why you try to install such an outdated version on an old server at all?

you only need the installer and the config file, nothing else

3 (edited by haxpor 2022-04-07 14:00:45)

Re: iredmail 0.9.2 didn't install anything from existing config file

Cthulhu wrote:

[ INFO ] Import installation process status from file: /root/Data/Projects/iRedMail-0.9.2/runtime/install.status


It skips everything because it asumes that all steps were already finnished

Why you try to install such an outdated version on an old server at all?

you only need the installer and the config file, nothing else

Thank you, I didn't really notice that

install.status

.
The reason is I'd like to do upgrade later after getting things up and running. As seen from listing page for instruction on how to upgrade for each version, it'd be elaborated and quite effort.

To my understanding, I would need to do incremental upgrade from 0.92 to 0.93, and so on until reach the latest version due to I still have to do upgrade changes for each incremental version?

Edit:
Ok I got it, it says in this page https://docs.iredmail.org/iredmail.releases.html that I should do upgrade from version to version.