1 (edited by johnk 2018-06-15 04:04:46)

Topic: Upgraded to Pro and now get 404 not found

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): iRedAdmin-Pro-SQL-2.9.0
- Linux/BSD distribution name and version: Ubuntu 16.04
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? Yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

OK. I upgraded from 0.9.8 to iRedAdmin-Pro-SQL-2.9.0. Now when I navigate to https://email.powersend.org/iredadmin/ I get 404 not found error. It used to work with the free version.

But I must say that I also created the website https://email.powersend.org on that server so we would have  a valid landing page should anyone look. Don't know if that created a problem with the default navigation created by the iRedMail install.
The hostname of the server is email.powersend.org also.

Any ideas how to fix this?
I am not an Ubuntu expert by any means but I have worked with it for about 6 months now.
Help would be appreciated. Thanks

2

Re: Upgraded to Pro and now get 404 not found

Thank very much for the purchase.

You should use "include" directive in email.powersend.org virtual host config file to include file /etc/nginx/templates/iredadmin.tmpl, so that it will serve the '/iredadmin/' url.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

3

Re: Upgraded to Pro and now get 404 not found

Nginx.conf includes sites-enabled
Here is the contents of sites enabled:

00-default-ssl.conf       
00-default.conf       
email.powersend.net.conf       
email.powersend.org.conf       
powersend.net.conf       
powersend.org.conf       
roundcube.powersend.org.conf

And here is the contents of 00-default-ssl.conf:

#
# Note: This file must be loaded before other virtual host config files,
#
# HTTPS
server {
    listen 443;
    server_name _;

    root /var/www/html;
    index index.php index.html;

    include /etc/nginx/templates/misc.tmpl;
    include /etc/nginx/templates/ssl.tmpl;
    include /etc/nginx/templates/iredadmin.tmpl;
    include /etc/nginx/templates/roundcube.tmpl;
    include /etc/nginx/templates/sogo.tmpl;
    include /etc/nginx/templates/netdata.tmpl;
    include /etc/nginx/templates/php-catchall.tmpl;
}

Do you mean i need to include 00-default-ssl.conf
in EVERY virtual host config?
Aren't they loaded in alphabetical order?

4

Re: Upgraded to Pro and now get 404 not found

johnk wrote:

Do you mean i need to include 00-default-ssl.conf in EVERY virtual host config?

No.

You're trying to access iRedAdmin-Pro under https://email.powersend.org/, so you need to make sure below line is part of your virtual web host config file (email.powersend.org.conf):

    include /etc/nginx/templates/iredadmin.tmpl;

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

5

Re: Upgraded to Pro and now get 404 not found

Thank you my friend for the help!
Hope you enjoy the coffee.
I understand now that it was only the configuration of  https://email.powersend.org/ that was interfering with iRedMail navigation. I have used your answer to also access Roundcube in the same manner.
Have a great day. I would close this topic but I don't see how to do that.
You may close it please.