1

Topic: Unknown (Chinese?) error when sending email

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 0.9.8
- Deployed with iRedMail Easy or the downloadable installer?: No
- Linux/BSD distribution name and version: CentOS 7.5
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MariaDB/MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro?: Yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

When trying to send an email a user is getting the attached error. It looks to me like the error given by the iRedMail server is in Chinese. (I'm not an expert in Asian languages, so I apologise if I have the language wrong.) The user does not read or write an Asian language and neither do I, so given the server is configured to use English I don't understand why the server would be giving out non-English error messages. I've never seen this before on my server, or any other.

A search for the error code implies it *might* because caused by an intermediary, like a firewall or ant-virus program. However, it still seems odd that the error is in an Asian language, so if nothing else a translation by someone would be useful. Thanks.


Craig

Post's attachments

cml_chinese_error_redacted.png
cml_chinese_error_redacted.png 15 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

2

Re: Unknown (Chinese?) error when sending email

It looks like a CJK word, but not.

As a Chinese user, i have experience that if your system or application doesn't have correct locale (character set) (e.g. en_US.UTF-8, zh_CN.UTF-8), the system or program may return some unknown characters or words.

I have no idea why this Outlook got this error. it might be something wrong with the Outlook itself due to can not handle the returned error message correctly, or the error message returned by upstream is messed.

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

3

Re: Unknown (Chinese?) error when sending email

Hi Zhang,

Thanks for your reply on this ... eight months ago! Sorry for not replying at the time, but I was travelling and stressed back in July last year. I think I was also confused by your reference to "... if your system or application doesn't have correct locale ...", but I later interpreted the "you" to be referring to the client system, not the server system.

Anyway, if that is correct you are probably right, as I do know that this particular user has some Chinese customers and it wouldn't surprise me if he has also done something weird with his machine to install multiple locales and has probably made an error. I don't recall how or if the issue was resolved at the time, but I don't believe he has received this error again, at least not to my knowledge.

Thanks, belatedly, for your help.


Craig