1

Topic: Sogo not showing mailbox - Active directory enabled

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.4.2 OPENLDAP edition
- Deployed with iRedMail Easy or the downloadable installer? Installer
- Linux/BSD distribution name and version: Debian 10
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): LDAP -> Active Directory
- Web server (Apache or Nginx): NGINX
- Manage mail accounts with iRedAdmin-Pro?: NO
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Ive just setup iRedMail and followed the guide to integrate the authentication to MS Active Directory. This all works. All check in the guide were ok, and I can login to SOGo with my test user. BUT, I only see the Personal Address Bok, Subscriptions and Global Address Book in the left menu. No Mail or Calendar.

Email does get delivered and I can see them in the /var/vmail/vmail1/xxxxs.xxx/testuser/Maildir/new folder.

Anyone any idea?

Post's attachments

Screenshot 2021-11-23 175334.png
Screenshot 2021-11-23 175334.png 29.27 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

2

Re: Sogo not showing mailbox - Active directory enabled

Found it.... Stupid me, in the sogo.conf file i left this part:

            ModulesConstraints = {
                Mail = { enabledService = sogowebmail; };
                Calendar = { enabledService = sogocalendar; };
                ActiveSync = { enabledService = sogoactivesync; };
            };

after a new install, and removing this code also it worked.

3

Re: Sogo not showing mailbox - Active directory enabled

Hello :
Can you show the content of the dovecot-ldap.conf file? Because my dovecot AD authentication always fails.Thanks a lot.

4

Re: Sogo not showing mailbox - Active directory enabled

hosts           = ad01.ad.example.com:3268
ldap_version    = 3
auth_bind       = yes
dn              = vmail@ad.exampe.com
dnpass          = whateverpasswordyouused
base            = cn=users,dc=ad,dc=example,dc=com
scope           = subtree
deref           = never

# Below two are required by command 'doveadm mailbox ...'
iterate_attrs   = userPrincipalName=user
iterate_filter  = (&(userPrincipalName=*)(objectClass=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))

user_filter     = (&(userPrincipalName=%u)(objectClass=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))
pass_filter     = (&(userPrincipalName=%u)(objectClass=person)(!(userAccountControl:1.2.840.113556.1.4.803:=2)))
pass_attrs      = userPassword=password
default_pass_scheme = CRYPT
user_attrs      = =home=/var/vmail/vmail1/%Ld/%Ln/,=mail=maildir:~/Maildir/,postOfficeBox=quota_rule=*:storage=%{ldap:postOfficeBox}G

this worked for and AD on windows ad 2016 level