1

Topic: unable to log on roundcude 5.2 bad gateway

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 0.9.8
- Deployed with iRedMail Easy or the downloadable installer? installer
- Linux/BSD distribution name and version: centos 7
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): active directory
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? no
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Hi Team,

I am getting the following error when trying to open roundcude but sogo works.

[error] 4182#0: *15193 connect() to unix:/var/run/php-fpm/php-fpm.socket failed (111: Connection refused) while connecting to upstream, client: 10.0.1.6, server: _, request: "GET /mail/ HTTP/1.1", upstream: "fastcgi://unix:/var/run/php-fpm/php-fpm.socket:", host: "192.168.30.22"


Could anyone advise please.

Regards,

rajbps

2

Re: unable to log on roundcude 5.2 bad gateway

Is php-fpm service running?

----

Does my reply help a little? How about buying me a cup of coffee ($5) as an encouragement?

buy me a cup of coffee

3

Re: unable to log on roundcude 5.2 bad gateway

ok it was that. Checking the service gave :

systemctl status php-fpm service
● php-fpm.service - The PHP FastCGI Process Manager
   Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled; vendor pres                                                   et: disabled)
   Active: failed (Result: signal) since Wed 2019-07-31 09:26:06 BST; 1 weeks 3                                                    days ago
  Process: 3768 ExecStart=/usr/sbin/php-fpm --nodaemonize (code=killed, signal=K                                                   ILL)
Main PID: 3768 (code=killed, signal=KILL)
   Status: "Ready to handle connections"
   CGroup: /system.slice/php-fpm.service

Warning: Journal has been rotated since unit was started. Log output is incomple                                                   te or unavailable.
Unit service.service could not be found.


restarted the service and now its working

systemctl start php-fpm.service

systemctl status php-fpm.service
● php-fpm.service - The PHP FastCGI Process Manager
   Loaded: loaded (/usr/lib/systemd/system/php-fpm.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2019-08-10 13:51:16 BST; 33s ago
Main PID: 13065 (php-fpm)
   Status: "Processes active: 0, idle: 5, Requests: 0, slow: 0, Traffic: 0req/sec"
   CGroup: /system.slice/php-fpm.service
           ├─13065 php-fpm: master process (/etc/php-fpm.conf)
           ├─13067 php-fpm: pool www
           ├─13068 php-fpm: pool www
           ├─13069 php-fpm: pool www
           ├─13070 php-fpm: pool www
           └─13071 php-fpm: pool www


unsure as to why a reboot did not bring it back in play.

Thanks again Zhang.