1

Topic: Compatibility with Debian 9.10

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 0.9.9
- Deployed with iRedMail Easy or the downloadable installer? Downloadable
- Linux/BSD distribution name and version: Debian 9
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MariaDB
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? No
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

I see Debian 9.10 has been released today which the Debian team recommend upgrading all previous versions to.
A dist-upgrade on my live iRedMail 0.9.9 server wants to upgrade the following packages - do you think there will be any compatibility issues with the iRedMail installation?

root@xxxxx:/home/xxxx# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following package was automatically installed and is no longer required:
  libclamav7
Use 'apt autoremove' to remove it.
The following NEW packages will be installed:
  libclamav9 linux-image-4.9.0-11-amd64
The following packages will be upgraded:
  base-files clamav clamav-base clamav-daemon clamav-freshclam clamdscan gettext-base grub-common grub-pc grub-pc-bin grub2-common libgd3 libglib2.0-0 libglib2.0-data libicu57 libldap-2.4-2 libldap-common libmariadbclient18
  libpam-systemd libsystemd0 libudev1 libxslt1.1 linux-image-amd64 linux-libc-dev mariadb-client mariadb-client-10.1 mariadb-client-core-10.1 mariadb-common mariadb-server mariadb-server-10.1 mariadb-server-core-10.1 openssh-client
  openssh-server openssh-sftp-server python3-reportbug reportbug systemd systemd-sysv udev unzip usbutils
41 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 88.5 MB of archives.
After this operation, 196 MB of additional disk space will be used.
Do you want to continue? [Y/n] n
Abort.

2

Re: Compatibility with Debian 9.10

For what it's worth I did the upgrade on 5 server running iRedMail 0.9.9 yesterday and have been monitoring it for the past 24 hours. Everything is working fine.

FYI, the upgrade, upgrades clamav and it will ask if you want want to use the existing clamd.conf or the new one. I choose the new one.

Make sure you have a fully functional backup before doing the upgrade.