1

Topic: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release): 1.0 MARIADB edition
- Deployed with iRedMail Easy or the downloadable installer?  how can I know?
- Linux/BSD distribution name and version: Ubuntu 18.04 LTS
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): MySQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? No
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Environment : test yet
iRedMail already installed. Using just SOGo & RocketChat.
Problem: SOGo can be access locally  (https://localhost/SOGo/) but the iRedMail administrator panel (https://localhost/iredadmin/) always showing "oops Page not found 404".

All the configuration was checked but can't make it work.
Administration Panel Path seems to be correct in /etc/nginx/templates/iredadmin.tmpl
( alias /opt/www/iredadmin/static/$1; )

and in /opt/www/iredadmin/static/:
default (directory)

js (directory)

logo.png (file)

also in /var/www/html: (root directory)

index.html

index.nginx-debian.html

mailchatclient (directory for mail integration with our product made in Laravel)
mount
robots.txt
vendor

Also /var/log/nginx/access.log:

127.0.0.1 -- feb ......." GET /_timesync HTTP/1.1" 200 13 "https://localhost/iredadmin/" "Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv;85.0) Gecko/20100101 Firefox/85.

Also /var/log/nginx/error.log:

(it doesnt appear in the administrator panel request, but just sometimes:)
2021/02/03 14:49:04 [error] 16514=16514 *23 connect() failed (111: Connection refused) while connection to upstream, client: 127.0.0.1, server: localhost, request "POST /sso HTTP/1.1", upstream "fastcgi://127.0.0.1:9999", host: "localhost:8000", referrer: "https://localhost/"

I can't reinstall because there were integrations so if I do it may broke a lot of things already working (mail
integration).

By now, using local ssl certificate.

I was hanging my head against the wall over the last 2 weeks but can't find the root cause of it..

Please kindly help!, (pls see screenshot in atach)
Thanks

Robert

Post's attachments

iRedMail-Error-404-2021-02-05 08:01:16.png
iRedMail-Error-404-2021-02-05 08:01:16.png 239.31 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

2

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

The log and screenshot are confusing.
The URL https://mailchat.taskcontrol.net/iredadmin/ returns http code 200 which means web page loads correctly (although it doesn't mean iRedAdmin loads, but the page is ok).

If it shows 404 page not found error, it means the template file /etc/nginx/templates/iredadmin.tmpl is not loaded.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

3 (edited by support@taskcontrol.net 2021-02-08 23:57:54)

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

Thanks for your reply. Sorry for the screenshot but I cannot copy & paste (I don't know why it doesnt enable me).

From left to right and upper to lower: Screen 1/4 showing still 404 page not found error
                                                           Screen 2/4 showing the include for iredadmin.tmpl in 00-default-ssl.conf
                                                           Screen 3/4 showing the access.log
                                                           Screen 4/4 showing both conf files are enabled

What to do next? No clue how to or where to check this error...
Thanks!
Robert

Post's attachments

iRedMail-Error-404-2021-02-08 12:52:13.png
iRedMail-Error-404-2021-02-08 12:52:13.png 228.7 kb, 3 downloads since 2021-02-08 

You don't have the permssions to download the attachments of this post.

4

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

Although "/etc/nginx/sites-available/00-default-ssl.conf" has "iredadmin.tmpl" included, but you modified the "server_name" parameter which EXCLUDES "localhost" (the hostname you visit in web browser).

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

5 (edited by support@taskcontrol.net 2021-02-11 10:24:04)

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

ZhangHuangbin wrote:

Although "/etc/nginx/sites-available/00-default-ssl.conf" has "iredadmin.tmpl" included, but you modified the "server_name" parameter which EXCLUDES "localhost" (the hostname you visit in web browser).


Thanks but I have changed in several ways..never works, with localhost nor with mailchat.taskcontrol.net

I have attached the screenshoot with server_name localhost, in 00-default.conf and in 00-default-ssl.conf.
Also in the lower right corner it shows the /etc/hosts so you can see what localhost is.

how should I modify or exactly what should I do to fix this 404 error?

Thanks!
Robert

Post's attachments

iRedMail-Error-404-2021-02-10 12:52:13.png
iRedMail-Error-404-2021-02-10 12:52:13.png 227.96 kb, 1 downloads since 2021-02-11 

You don't have the permssions to download the attachments of this post.

6

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

Please turn on debug mode in Nginx and check which directory/file it actually accessed.
FYI: https://docs.iredmail.org/debug.nginx.html

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

7 (edited by support@taskcontrol.net 2021-02-12 23:27:48)

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

ZhangHuangbin wrote:

Please turn on debug mode in Nginx and check which directory/file it actually accessed.
FYI: https://docs.iredmail.org/debug.nginx.html

ok, I have set the debug mode since the beginning but the only weird thing that I see is the error messaje in the error.log (what do they mean?)

in the atach image:

upper right windows you can see the debug and restarted nginx
lower right widows you can see the weird error in the error.log
lower left windows all the ports opened by the firewall (ufw)...just in case ....

Thanks!

Post's attachments

iRedMail-Error-404-2021-02-11.png
iRedMail-Error-404-2021-02-11.png 257.36 kb, 2 downloads since 2021-02-11 

iRedMail-Error-404-2021-02-12 12:27:10.png
iRedMail-Error-404-2021-02-12 12:27:10.png 229.63 kb, 1 downloads since 2021-02-12 

You don't have the permssions to download the attachments of this post.

8

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

I don't see your Nginx site config file has "/etc/nginx/templates/iredadmin.tmpl" included / loaded.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

9

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

ZhangHuangbin wrote:

I don't see your Nginx site config file has "/etc/nginx/templates/iredadmin.tmpl" included / loaded.


ok, here it goes again (btw, in the first screenshoot shows that SOGo is working perfectly...).. in the second nevertheless, iredadmin keeps sending "404 Page not Found"...
Help please!
Thanks!

Post's attachments

IRedAdmin-Not-Working-2-of-2.png
IRedAdmin-Not-Working-2-of-2.png 209.93 kb, 2 downloads since 2021-02-22 

Sogo-Working-1-of-2.png
Sogo-Working-1-of-2.png 190.35 kb, 1 downloads since 2021-02-22 

You don't have the permssions to download the attachments of this post.

10

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

Please show the full config file of the one under /etc/nginx/sites-enabled/ (or sites-available).
There's no "server_name" in screenshot, hard to know whether you're accessing the correct web host.

Any error in Nginx log files? Which file/directory is it trying to access?

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

11

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

Hi, ataching left windows 00-default.conf, righ windows 00-default-ssl.conf.
The logs are the ones I have post it in the screenshots before.
access.log= access /iredadmin/
error.log= show those errors just when I stop and restart the nginx server..

Thanks!

Post's attachments

IRedMail-Configuration-Files-25-02-2021.png
IRedMail-Configuration-Files-25-02-2021.png 243.29 kb, 2 downloads since 2021-02-25 

IRedMail-Configuration-Files-25-02-2021.png
IRedMail-Configuration-Files-25-02-2021.png 243.29 kb, 2 downloads since 2021-02-26 

You don't have the permssions to download the attachments of this post.

12

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

- Your "server_name" is limited to one domain name, so you can not access it with "https://localhost/". This was mentioned in early reply.
- Please copy text and paste here, do NOT capture a screenshot with the text (it's harder to check and waste web server disk space).

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

13

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

Thanks. I was uploading images because is better understand all the picture.
Also "localhost" is working for SOGo why should'nt with iredadmin??
Please tell me exactly what I need to set so this module can work.
21 days sending info and still no solution.
How many cost a few minutes of your support to check and fix the error thru Teamviewer?
Thanks

14

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

support@taskcontrol.net wrote:

Also "localhost" is working for SOGo why should'nt with iredadmin??

If you have a domain name in "server_name", then only this domain name will trigger the configuration in this "server {}" block.

If SOGo works for "localhost", that means the "server {}" block which supports "localhost" has related configuration for SOGo, that doesn't mean other "server {}" block has same configuration.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

15

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

ZhangHuangbin wrote:
support@taskcontrol.net wrote:

Also "localhost" is working for SOGo why should'nt with iredadmin??

If you have a domain name in "server_name", then only this domain name will trigger the configuration in this "server {}" block.

If SOGo works for "localhost", that means the "server {}" block which supports "localhost" has related configuration for SOGo, that doesn't mean other "server {}" block has same configuration.

Thanks. ok, I have tried with localhost in .conf and still does not work. I'm in GMT-3 please tell me day and time when you can fix this problem. There is too much delay with this task that is one among one hundred task I need to make it work. I can't put more time on this.
Thanks!

16

Re: iRedMail Admin Panel doesn't appear showing "Page not Found 404"

You can purchase a support ticket for this:
https://www.iredmail.org/support.html

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee