1 (edited by bardigulmo 2021-04-03 17:11:09)

Topic: Not being able to access webserver PR_END_OF_FILE_ERROR

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release):  1.3.2
- Deployed with iRedMail Easy or the downloadable installer? Downloadable installer
- Linux/BSD distribution name and version: Debian 10
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): PGSQL
- Web server (Apache or Nginx): Nginx
- Manage mail accounts with iRedAdmin-Pro? No
- Server hosting: Vultr
- Web server domain: mail.zvejoargenu.com
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====
After running for three months letsencrypt certificate renewal through crontab seems to fail. After I catch an error on the server tried to renew certificates manually, which did work, but broken all the configuration. Now it's not possible to access OpenCube, as well as connect via mail client, such as Thunderbird. It passes check but isn't able to proceed. journalctl -xe doesn't show any particular problem. As or the certificate error, here is Nginx configuration.

Looking for help sincerely.

Post's attachments

nginx-ssl.conf 821 b, 2 downloads since 2021-04-03 

nmap-A-d.txt 29.48 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.

2

Re: Not being able to access webserver PR_END_OF_FILE_ERROR

Did you restart postfix + dovecot + nginx services to load new cert/key files after renewed manually?

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

3

Re: Not being able to access webserver PR_END_OF_FILE_ERROR

Yes, I do believe I restarted everything after renewal.

4

Re: Not being able to access webserver PR_END_OF_FILE_ERROR

Would it be ration to backup every database and create a new install of iRedMail and transport everything where it belongs? Or in such case basically required?

5

Re: Not being able to access webserver PR_END_OF_FILE_ERROR

The nginx config file already includes "/etc/nginx/templates/ssl.tmpl", it contains directives "ssl_certificate" and "ssl_certificate_key", but you have these two directives in /etc/nginx/sites-enabled/00-default-ssl.conf. Please remove them from 00-default-ssl.conf and try again.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee