1

Topic: Enable "Relay without verifying local recipients" from command line

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release):     1.3.2
- Deployed with iRedMail Easy or the downloadable installer? installer
- Linux/BSD distribution name and version: ubuntu 16.04
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): ldap
- Web server (Apache or Nginx):
- Manage mail accounts with iRedAdmin-Pro? yes (4.5)
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Hi, currently I am stuck on an older iredmail version, where the button for "Relay without verifying local recipients" is greyed out/does not work.

I know the next update fixes it, but that system is old and will be shut down, so doing an OS upgrade + iredmail upgrade is not in any proportion to ticking a checkbox wink

can I set this option in the database manually?

2

Re: Enable "Relay without verifying local recipients" from command line

Sure. In SQL table "vmail.domain", set "backupmx=1", also set proper relay in column "transport".

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

3

Re: Enable "Relay without verifying local recipients" from command line

ZhangHuangbin wrote:

Sure. In SQL table "vmail.domain", set "backupmx=1", also set proper relay in column "transport".

Thank for your answer.
Unluckily I cannot find that table, maybe because my backend is LDAP?

Also backupmx sounds wrong (at least from my non code knowing side).

Just to be sure, I'm talking about this checkbox:

https://i.imgur.com/MBGmxzq.png


And NOT about this:
https://i.imgur.com/hsVa7IJ.png

4

Re: Enable "Relay without verifying local recipients" from command line

lug wrote:

Unluckily I cannot find that table, maybe because my backend is LDAP?

Set "domainBackupMX=yes" for that domain, also update "mtaTransport" attribute with a proper relay.

I understand your concern, but this is a trick to get proper ldap query result returned to Postfix. smile

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee

5

Re: Enable "Relay without verifying local recipients" from command line

ZhangHuangbin wrote:
lug wrote:

Unluckily I cannot find that table, maybe because my backend is LDAP?

Set "domainBackupMX=yes" for that domain, also update "mtaTransport" attribute with a proper relay.

I understand your concern, but this is a trick to get proper ldap query result returned to Postfix. smile

Well, I don't get it working.

I jusst ended up deleting the domain and rereating it as backupmx domain, which works smile
Sometimes I just think to complicated and don't see the easiest ways big_smile