1

Topic: Domain Alias not working for existing mailboxes

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release):      1.4.0
- Deployed with iRedMail Easy or the downloadable installer? downloadable installer
- Linux/BSD distribution name and version: Debian 10 (Buster)
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): 4.8 (MySQL)
- Web server (Apache or Nginx):NginX
- Manage mail accounts with iRedAdmin-Pro? yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Hello,

i am issuing with the Domain Alias. I created a Domain @example.de, where i created many users with the script and some by myself. After that, i added the Domain Alias @demo.de for the @example.de Domain. Some mailboxes were created after adding Domain Alias.

The issue now is, that the Domain Alias works perfect for the users which were created after setting the Domain Alias. But for users which i created before setting the Domain Alias, it does not work.

Error says: <1530@demo.de>: host mail.demo.de[81.20.113.89] said: 550 5.1.1
    <1530@demo.de>: Recipient address rejected: User unknown (in reply
    to RCPT TO command)

I am looking forward to a solution.

Enrico

2

Re: Domain Alias not working for existing mailboxes

e.abend@goetel.de wrote:

==== REQUIRED BASIC INFO OF YOUR IREDMAIL SERVER ====
- iRedMail version (check /etc/iredmail-release):      1.4.0
- Deployed with iRedMail Easy or the downloadable installer? downloadable installer
- Linux/BSD distribution name and version: Debian 10 (Buster)
- Store mail accounts in which backend (LDAP/MySQL/PGSQL): 4.8 (MySQL)
- Web server (Apache or Nginx):NginX
- Manage mail accounts with iRedAdmin-Pro? yes
- [IMPORTANT] Related original log or error message is required if you're experiencing an issue.
====

Hello,

i am issuing with the Domain Alias. I created a Domain @example.de, where i created many users with the script and some by myself. After that, i added the Domain Alias @demo.de for the @example.de Domain. Some mailboxes were created after adding Domain Alias.

The issue now is, that the Domain Alias works perfect for the users which were created after setting the Domain Alias. But for users which i created before setting the Domain Alias, it does not work.

Error says: <1530@demo.de>: host mail.demo.de[81.20.113.89] said: 550 5.1.1
    <1530@demo.de>: Recipient address rejected: User unknown (in reply
    to RCPT TO command)

I am looking forward to a solution.

Enrico


I´ve found the issue and the solution for it. After adding a Domain Alias, the system automatically adds a line in mysql forwardings table for a new created user, which is needed for the Domain Alias to work. But it does not add this data for the existing users and theres the problem, because that line in the forwardings table is needed for the Domain Alias. I wrote a simple short script for it and added it with the script for my existing mailboxes.

@iRedMail-Support Please fix this issue with a patch for future people to not have this issue

3

Re: Domain Alias not working for existing mailboxes

- This is not a bug of iRedAdmin-Pro.
- It's an issue of your own script used to create user, it must add a record in `vmail.forwardings` for each mailbox.

----

Buy me a cup of coffee ($5) to support iRedMail:

buy me a cup of coffee